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Digital Signature Certification Workflow 
 

This document goes through a workflow of how to create a set of plans that contain 
an Adobe CDS digital signature using Adobe Acrobat Pro DC.  There are several 
variances on how this can be done.  Engineers should use their discretion on how to 
apply their seal, signature and date to abide by the Engineering Boards Regulations.   

 
A. Definitions: 

 
a. A digital signature is a mathematical scheme for demonstrating the authenticity of a digital message 

or document. A valid digital signature gives a recipient reason to believe that the message was 
created by a known sender, and that it was not altered in transit. The Design Division uses the 
technology from the Entrust Company to authenticate our digital signatures.   

 
b. An electronic signature is any legally recognized electronic means that indicates that a person 

adopts the contents of an electronic message, such as a scanned representation of an individual's 
signature imported into a document, or electronic file. 

 
B. Adobe CDS Certificates: 

 A list of providers for the CDS certificates can be found at the Adobe website at the link listed below.  
Any of these companies can be used to provide the certificate. 
 

www.adobe.com/security/partners_cds.html 
 

C. Creating the Engineer’s Seal from a MicroStation Cell as a File to Use as a Watermark. 
a. Open a blank MicroStation DGN file.  Place the seal at a scale of 1. 
b. In MicroStation, go to File>Print  
c. Under Printer and Paper Size, change to Bentley Driver and select TDOTjpeg.plt  
d. Rotation should be set to No Rotation and Print Scale to 0.5 
e. Go to File>Print and enter a name for the file.  This file is your Engineer’s Seal for Watermark. 

 
D. Creating the Electronic Generated Signature and Date as a file to Use as a Watermark. 

 
NOTE: This workflow can only be performed by the Registered Professional Engineer that is sealing 
the plans and cannot be designated to any other person to affix the signature and date. 
 
This is only one method for creating your digital signature appearance with an image of your actual signature.  
Other processes are available, so use what is most familiar to you. 
 
 

a. Scan your signature into a file.  Cropping may be required and can be done through Adobe Acrobat or 
other editing software.   
 

b. The background for the signature needs to be transparent.  There are many programs that can be 
used to do this including Adobe PhotoShop, Illustrator, Streamline and GIMP.     

 
c. If you did not use Adobe Acrobat to crop the file, the electronic signature file must be made into a pdf.  

Open Adobe Acrobat and navigate to File>Create>PDF From File.  Select the file that you just 

created and then select Open.   
 

d. Add the date field for date to the signature pdf image. 
i. Navigate to Tools>Prepare Form 
ii. Select a file or scan document, select Use the current document or browse to a file, then 

hit Start   
iii. Navigate to Add a Text field 

 
 

http://www.adobe.com/security/partners_cds.html
http://www.adobe.com/security/partners_cds.html
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e. Move the cursor over the document and notice the blue box that is attached to the end.  Put this in the 
general area that you want the date.  The date field can be resized by using the mouse and clicking on 
the blue squares around the field box.  Also, the field can be moved by using the mouse and clicking 
anywhere inside the field box.  

 
 

 
 

 
 

f. Double-click on Text1 or right click in the shaded box and go to Properties.  The Text Field Properties 
box will appear. Select the Format tab at the top.  Select the format category as Date and format as 
mm/dd/yyyy.   Click on the Format tab and select Date as the Select format category.  When 
finished, select Close.  In the Tasks window on the right, choose Close Form Editing.   

 
 

 
 
 

g. Save the file. 
 

h. Inside the pdf, click in the date field and enter the date.  If the date is not entered correctly, a warning 
message will appear.   
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i. Save the file when you are finished.  This file is your Signature and Date for the watermark. 
 

NOTE:  When signing a set of plans with a different date, you will need to open this file and 
modify the date each time and save it.  You do not need to create a new file for each date, just 
overwrite the one that you have.     

 
 

E. Adding the Electronic Generated Seal and Signature as a Watermark 
 
Note:  It is not required to add the engineer seal as a watermark.  It can be done in each MicroStation .SHT 
file if preferred. 

 
a. Once the pdf of the plan set is created, open Adobe Acrobat and navigate to Tools>Edit 

PDF>Watermark>Add 
 

 

 
 

 

b. The Add Watermark dialog box will open.  In the Source section, click on File.  This allows you to 
choose the image for the watermark.    Select the Browse button and navigate to the file that contains 
your electronically generated seal.  Once the file is selected, click Open. 

 
 
 

c. In the Preview window, you may notice that your seal is large.  To correct this, set the Absolute Scale 
to a different scale to size the seal correctly.  The scale relative to target page could also be adjusted. 
 

d. In the Appearance dialog box, select Appear behind page.   
 

e. In the Position section, change the Vertical and Horizontal Distance to place the seal in the seal box.  
In the Preview dialog, you can go to a different page to see the location of the seal on the plans.   
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f. In the upper right corner, click the Page Range Options.  Select Pages from and change it to start at 
page 2.  Click OK.  Starting the watermark at page 2 is so that the signed and dated electronic 
generated signature watermark will not appear on the Title sheet.  This is because the seal box is 
located at a different location than the rest of the sheets.  The title sheet watermark will be added 
separately. 

 

 
 

g. Once the settings are correct, choose Save Settings and give it a name.  The settings can then be 
pulled up each time a watermark needs to be applied on a plan set.   
 

h. Click OK on the Add Watermark dialog.  The engineer seal should now appear as a watermark on 
each sheet.   

 
i. To add a Signature and Date as Watermark navigate to Tools>Edit PDF>Watermark>Add choose 

Add New on the next dialog window. Follow the procedure as above to watermark Signature and Date. 
 

 
 

j. To add the Watermarks to the title sheet, follow the procedure as above.    When you get to the page 
range options, choose the title page only. 
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F. Creation of Signature Sheet in MicroStation 
 
a. Create a new MicroStation SHT File, seed with Signature Sheet.dgn  
b. Copy all the information from first column to second column.  Repeat this step for each PE responsible 

for plan sheets. 
c. Modify the Signature information for each PE responsible for the plan sheets.  This information is the 

white text above the index.  Select Fill in Single Enter–Data Field, edit text to your company 
information.  For TDOT employees, this should say Tennessee Department of Transportation and the 
physical address of your office location.   

  

 
 

d. Modify the linked index.   Select and open the linked document, make edits to the index to include the 
plan set for which the PE is responsible.  Save linked document.  Repeat the previous step for each 
responsible PE.   

  

 



6 

 

 
 

e. Place Engineer Seal in corresponding column for Sheets. Since the seal is only placed on one sheet 
seal is placed as a cell in this example. Select Place Active Cell navigate to location of seal and place 
at scale of 1.   Repeat the previous step for each responsible PE.   If preferred seal can be placed as a 
watermark. 
 

 

 
 
 

f. Print sheet as a pdf.  Using the Setting File PdfEnglishFul.set. 
 
Note:  If additional space for PE information is needed, addition Signature Sheets can be 
created. 

 
G. Creation and Appearance of Digital Signature 

 
a. Create digital signature appearance, open Adobe Acrobat and navigate to Edit>Preferences 
b. From the Preference dialog box, navigate to Signatures. 
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c.   Under Creation & Appearance click the More Button, the following dialog will open. 
 
 
 

 
 

 
d.   Under Appearances click the New, following dialog will open.  Create new Signature. 

 
 
 

 
 
 
 
 

H. Signing and Certifying a Document 
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a. Open the completed Signature Sheet from Step F in Adobe Acrobat. 
b. Sign using Signature Blocks, navigate to Tools>Prepare Form>Add a Digital Signature.  Place 

signature block in empty box under “THIS DOCUMENT HAS BEEN SIGNED AND SEALED BY:” right 
click on Signature field and select properties.  Change properties to the following: 
 

 
 

 
c. Repeat the previous step for each responsible PE.  
d. Save document. 
e. The Design Manager or Consultant Engineer responsible for the majority of the sheets will be 

responsible for certifying the sheets while all other responsible PE’s will only have to digitally sign the 
final document.  Navigate to the Signature field, right click, and select Certify with Visible Signature. 
Modify the dialog box to the following:   

 

 
 
 

i. In the Reason section, you can leave it blank or choose a reason if needed.   
ii. In the Permitted Actions After Certifying section, select No Changes Allowed.  If multiple 

signatures will be on a sheet, then change this to Form Fill-in and digital signatures. 
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f. The electronically generated digitally certified signature now appears on the sheet.  The blue ribbon at 
the top of your document that shows that the file is certified.   

 
 
 

 
 

 
 

g. Save the pdf and send to any remaining PE’s for Signature. 
h. Keep a separate copy of the Certified Signature Sheet.  Below is an example of a project with multiple 

signatures, TDOT developed projects will generally only contain one signature.  
 

 
 

 
 



10 

 

 
I. Revisions to Plan Set  

a. In order to complete a revision on a previous sealed sheet you must first remove the certification. 
b. Open Certified Signature Sheet, navigate to File >Print.  Under Printer select Adobe PDF, select the 

properties button.  The following dialog box will open.  
 

 

 
 

c. Scroll down to the Adobe PDF Page Size and Select Add.  The following dialog box will open.  Add a 
custom paper size of 33 X 21 to match TDOT sheet size. 

 
 

 
 

d. Navigate to Layout and change Orientation from Portrait to Landscape. Print the signature sheet. 
e. Create Signature Sheet Sign2 following same process listed in Step F (Creation of Signature Sheet in 

MicroStation). 
f. Add a revision note in the upper right corner of the Signature Sheet - Revision Date:  Added Sheet.   
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f. For revisions all signature sheets will be included in the final pdf document. 
 
 

J. Sheet Number Naming Convention  
a. This workflow follows the normal Digital Signature Certification process for the Design Division, for 

other divisions follow the Standard Signature Sheet naming below: 
 

 

DIVISION/SECTION SHEET NAME 

Roadway Design ROADWAY-SIGN1 

Structures -Bridge BRIDGE-SIGN1 

Geotechnical GEOTECH-SIGN1 

Signal Design SIGNAL-SIGN1 

Lighting Design LIGHTING-SIGN1 

ITS ITS-SIGN1 

Natural Stream Design  NS-SIGN1 

Structures – Retaining Wall R-SIGN1 

 
b. If multiple Signature Sheets are needed, naming convention will follow the format above and be listed 

in the Index as Division/Section-SIGN1-X, where X represents last sheet number used. 
 

 
 

 


