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Introduction to V8i on Windows 7 

1. Introduction 
Information in this document is based on MicroStation V8i (SELECT Series 2) version 08.11.07.443, 
Geopak V8i (SELECT Series 2) version 08.11.07.615, Office 2010 and Projectwise Interplot Organizer V8i 
version 08.11.07.420 on the Windows 7 operating system. 

This document is intended as an introduction of this new software for T.D.O.T. Roadway Design Division 
users who are switching from MicroStation and Geopak V8 2004 on Windows XP. 

 It includes the following: 

• Local settings to finalize PC set ups 
• Adjustments to current project settings 
• Changes to current functions and new functions 

General Software Enhancements 
• Task oriented tool navigation  

• More advanced video control allowing transparencies and other visual effects not previously available. 

• Dynamic view manipulations 

• Color filled fences and view window area 
  

 

 

 
Tennessee Department of Transportation. Authorization Number 401512, 400 copies, April 2013. This public 
document was promulgated at a cost of $3.55 per copy. 
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2. Windows 7 System Set Up 

Program Access 
Click on the Windows Start icon and then click on All Programs. 

 
Programs appear in a folder structure for easy navigation.  
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Workspace Appearance 
Right click on the desktop and pick the option Personalize to control system colors, themes, etc. 
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Attach InterPlot Plotters 
Our InterPlot (Iplot) software now requires that plotters must be connected to you PC in order to plot to 
them. Click on the Start icon and click in the search text field. Type in the plot server for your location and 
hit enter. 

Headquarters  \\jj00wf18 
Region 1  \\JJ01WF03 
Region 2  \\JJ02WF03 
Region 3  \\JJ03WF03 
Region 4  \\JJ04WF03 

 
Select all plotters you wish to have available for plotting. Once selected, right click over one of them and 
choose the option Connect. 
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Set Default Printer 
Local printers are connected automatically but you will need to set your default printer. Click on the Start 
icon and go to Devices and Printers. Right click over the printer you want and choose the option Set as 
default printer. 

  

Download Iplot Settings files 
T.D.O.T. Roadway Design Division personnel will need to go to the intranet CADD web page and 
download the Iplot settings files for your location. . 
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Windows Explorer 
Classic Menu Bar Options 
To show classic menu bar options (File, Edit, View, Tools, Help) go to Organize > Layout> Menu bar. 

 
Folder Paths 
Click on any folder in the address bar to jump to that folder. 
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Click to the right of the folder path to get the standard folder path for copying from or pasting to the address 
bar. 

 
Data from the D drive on old T.D.O.T. Roadway Design Division computers are added to new PCs under 
the folder D Drive. All roadway project folders should be moved to C: to maintain the original folder paths. 
These folder paths will have to be adjusted in certain files such as the Geopak project and it is less 
problematic to only change the drive letter.  

 
T.D.O.T. Roadway Design Division CADD Standards are now located under C:\Users\Public. 
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3. Office 2010 Set Up 
This is the recommended set up for Office 2010 when using the T.D.O.T. Design Division templates and 
programs. If Office templates are not installed to the default folders, then the directions will need to be 
modified accordingly. 

Do this one time only when using Word and Excel 2010 for the first time with the TDOT templates and 
programs. This must be done for each user profile that will be using Office 2010 to link with MicroStation. 

Word 
1. In Word 2010, click on the File tab at the far left of the ribbon and choose Options from the drop down 

list. 
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2. In the Word Options dialog click on Save in the options on the left.  

Set the Save Files in this format: option to Word Document (*.docx). 
Use the Browse button to the right of Default File Location: to set the folder where you wish all Word 
documents to be saved by default. 
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3. In the Word Options dialog, click on Advanced in the options on the left. Scroll down to the General 
section and click the File Locations button. 

 
Click on User Templates and then click on the 
Modify button.  

Navigate to and set the folder 
C:\Users\Public\Office Standards. Click OK to 
save the setting.  

This will set the default template location for both 
Word and Excel so that the TDOT template folders 
will be available. 
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4. In the Word Options dialog, click on Trust Center in the options on the left. 

 Click on the Trust Center Settings button. 
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5. In the Trust Center dialog, click on Trusted Locations in the options on the left. Select the trusted 
location for Application Templates.  
All files stored under Trusted Locations will automatically load macros without any action from the 
user. 

 
The settings for Application Templates are at the bottom. The Path should be set to 
C:\Users\Public\Office Standards and Sub Folders should be set to Allowed.  

Click on the Modify button. In the dialog which opens, click on the Browse button and set the path. 
Then click on the Subfolders of this location are also trusted option and click OK. 
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6. In the Trust Center dialog, click on the Add new location button. 

Click on the Browse button and navigate to the location where your project files are stored.  
Click on the Subfolders of this location are also trusted option, key in a description if desired and 
click OK.  

 

With your project folders defined as trusted locations, all macros will automatically be enabled.  
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If you open a Word 2010 file with macros that is not in a trusted location, the following two 
settings will provide you the opportunity to enable the macros as needed. 

7. In the Trust Center dialog, click on Macro Settings in the options on the left. The option Disable all 
macros with notification should be set.  

 
8. In the Trust Center dialog, click on Message Bar in the options on the left. The option Show the 

Message Bar in all applications when active content, such as ActiveX controls or macros, has been 
blocked should be set.  

 
9. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings just made. 

10. This completes the settings under Word Options, so click the OK button at the bottom of that dialog to 
complete the Word 2010 set up.  
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Excel 
1. In Excel 2010, click on the File tab at the far left of the ribbon and choose Options from the drop down 

list. 
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2. In the Excel Options dialog click on Save in the options on the left.  

Set the Save Files in this format: option to Excel Workbook. 

Change the path given for Default File Location: to set the folder where you wish all Excel documents 
to be saved by default. 
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3. In the Excel Options dialog, click on Trust Center in the options on the left. 

 Click on the Trust Center Settings button. 
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4. In the Trust Center dialog, click on Trusted Locations in the options on the left. Select the trusted 
location for Application Templates.  

All files stored under Trusted Locations will automatically load macros without any action from the 
user. 

 
The settings for Application Templates are at the bottom. The Path should be set to 
C:\Users\Public\Office Standards and Sub Folders should be set to Allowed.  

If sub folders are Disallowed, click on the Modify button. In the dialog which opens, click on the 
Browse button and set the path. Then click on the Subfolders of this location are also trusted option 
and click OK.  
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5. In the Trust Center dialog, click on the Add new location button. 

Click on the Browse button and navigate to the location where your project files are stored.  
Click on the Subfolders of this location are also trusted option, key in a description if desired and 
click OK.  

 

With your project folders defined as trusted locations, all macros will automatically be enabled.  
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6.  In the Trust Center dialog, click on Macro Settings in the options on the left. The option Disable all 
macros with notification should be set.  

 
7. In the Trust Center dialog, click on Message Bar in the options on the left. The option Show the 

Message Bar in all applications when active content, such as ActiveX controls or macros, has been 
blocked should be set.  

 

8. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings just made. 

9. This completes the settings under Excel Options, so click the OK button at the bottom of that dialog to 
complete the Excel 2010 set up.  
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Excel Estimated Roadway Quantities Items.dat File 
Since this is a new installation of Office you will need to download a copy of the Items.dat file for use by 
various macros in estimated roadway quantities Excel files. 

Access the items web page at: 

http://www.tdot.state.tn.us/RoadItemLists/roaditem_index.htm 

Follow the directions shown on the right of the web page to save the items.dat file to the folder location 
C:\Users\Public\Office Standards\TDOT 2nd Sheets.  

  

 
  

http://www.tdot.state.tn.us/RoadItemLists/roaditem_index.htm
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4. MicroStation Set Up 

Set Up New MicroStation User 
Since permissions are more restricted on Windows 7 systems, you must set up your own MicroStation user 
so that it will remember various options such as the interface and tool layouts that you set. Click on the 
Untitled user and choose the New… option. 

 
Type in a Name and click OK. You can add a description if desired in the second dialog although it is not 
required.  Click the Select button for the User Interface and set it to tdot.  T.D.O.T. Roadway Design 
Division personnel should not change the other options. Click OK to save the settings. 

   

TDOT Interface 
The interface should now be set to tdot, if not, use the drop down options to set the Interface to tdot. 
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Activate Geopak 
When you first open MicroStation, you will need to Activate Geopak. Go to Applications > Geopak and 
click that option.  

If there is no Applications menu bar option or Geopak is not under there, T.D.O.T. Roadway Design 
Division personnel should contact their local IT personnel to update your Geopak configuration so that it 
will start automatically with MicroStation. 

 

MicroStation Interface 
Position Mapping 

By default, Position Mapping is on which allows keyboard shortcuts for MicroStation functions. The 
blue boxes with characters shown by default are position mapping aids which are controlled through 
Preferences. 
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MicroStation Preferences 
Go to Workspace > Preferences to personalize the way you want MicroStation to function.  

Make settings as desired in sections Look and Feel, Mouse Wheel and Operation. 

      
If you do not want to use Position Mapping, turn it 
off or perhaps just turn off the mapping aids once 
you know them. You can set the keyboard short cuts 
from here. 
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Make the settings shown for optimal use of Raster Manager. The settings in the Georeference section 
must be made as shown to use our MrSID county wide aerial photos. 

      
Under Reference make the settings shown including 
Remap Colors on Copy: Off, Reload When 
Changing Files: On and Display Raster References: 
Off. 

Task Navigation provides control over the size and 
Presentation mode of this new tool navigation 
functionality. 
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View Options include several controls for views including the Show View Toolbox location which you may 
wish to switch to the bottom as it was in previous software versions.  

You may wish to turn on Scroll bars on View Windows or change the Element Hilite Color and Selection Set 
Color used in all files. 

 
AccuDraw 
If you are not a constant user of AccuDraw you may wish to go to Settings > AccuDraw to cut off the Auto 
Load option. 
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Snap Button Bar & AccuSnap 
Click on the Snap Icon at the bottom on the Status Bar and choose Button Bar to open the Snap Button Bar 
for use. 

 
Right click over AccuSnap on the Snap Button Bar and choose Properties or from the Status Bar snap 
options pick AccuSnap to open its properties. 

    

Click off Enable AccuSnap if you do not want it on by default. 

WARNING:  
You very likely will want to turn off Identify Elements Automatically. 
This effects all element identifications and if on you will not get 
Accept/Reject options to skip elements as in previous versions. 

Keyin Field 
Go to Utilities > Key-in to open the Key-in dialog. 

 
This functions as it has in the past and can be shrunk to just the Key-in field for easy docking. 
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Task Navigation and Workflows 
MicroStation Root Tasks 
MicroStation’s Main root tasks include the most commonly used non-drawing tools. These are the 
Selection Set, Fence, Manipulate, Change Attributes, Groups, Modify, Measure and Delete tool groups. 

The most commonly used drawing tools are found in the Drawing task group. 

In the Main root you can click and hold the mouse button down to access the other tools in the group. 

 \ 

At the bottom of Task tool groups is an option to Open “name“ as Toolbox which can help when you are 
jumping back & forth between tools. 

 
Task Layout Modes 
Task tool groups including the root tasks can be displayed in 3 different modes.  

Icon Layout Mode      List Layout Mode 
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Panel Layout Mode 

Pinned vs. Un-Pinned 
Notice the stick pin icon at the upper right of the Task Navigation. This allows the tools to be “pinned” in 
place. If you click this icon and un-pin them they will auto-shrink away when your cursor moves away.  

When your cursor nears it when un-pinned, the tools pop back out for your use. This can be advantageous 
when screen space is limited and you want to get tools out of the way. 

Pinned          Un-Pinned    Tasks when un-pinned 
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Dialog Docking Control 
MicroStation now includes docking controls for its dialogs that will allow you to dock dialogs to the left or 
right or at top or bottom.  When you grab a dialog and start to drag it, the software automatically shows 
docking locations that are compatible.  

Left or Right 

 
Tool Settings docked on right 
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Top or Bottom 

 
References docked on top 

 
  



32 

Civil Workflows 
Workflows are a grouped set of tools, task groups and even other workflows. MicroStation includes a 
workflow called Drawing Composition which sets up sheets but not as we do them so it will probably not be 
used by us. Geopak Suite includes several different workflows but we recommend Civil Workflows for our 
T.D.O.T. Roadway Design Division users. It includes tools and task groups most commonly needed by our 
personnel in Survey & Roadway Design. 

Clicking on the workflow icon activates that workflow and adds common Geopak tools to the task root 
including Project Manager, Geopak Attributes, Active Chain Control, Corridor Modeling, Design & 
Computation Manager and Geopak Help. Several task groups and workflows are made available as well. 

  
Some of the task groups which are available using Civil Workflows: 
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To back out of all workflows, right click in the task root area and choose Clear Task Root. When you have 
more than one workflow active, you can click on the workflow tab at the top to go back to that workflow. 

 
MicroStation & Geopak Classic Toolboxess 
The TDOT Design Division Toolbox includes access to classic MicroStation & Geopak tool boxes. 
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5. CADD Standards & Project Folder Changes 
The new default location for T.D.O.T. Design Division’s CADD standards is under C:\Users\Public and for 
many users the following sections should be reviewed as this affects their old project data. The new PCs at 
the Roadway Design Division only have a C: drive so if projects were originally on the local D: drive then 
the move to C: drive will affect some things as well. 

MicroStation DGN Reference Files 
DGN reference files do not need adjustment as long as the folder structure is maintained. The change from 
D: to C: should not cause a problem.   

The Browse button in the Attachment Settings dialog can be used to update reference file attachments 
anytime the filename or folder structure is altered. 

 

MicroStation Raster File Attachments 
Raster file attachments do not need adjustment as long as the folder structure is maintained. The change 
from D: to C: should not cause a problem.  

If you need to update raster file attachments anytime the filename or folder structure is altered, in Raster 
Manager go to Utilities > Filename. In the File Name dialog revise the name or use the search button to 
identify it. 
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Another issue may cause an attachment to not appear in a given view. Raster attachments are tied to a level 
but that did not matter in the previous software. V8i does now honor this so if the level is turned off in the 
view, the attachment will not show. Notice view 1 is greyed out in the image shown below. 

 
Element information can be used to verify the level the raster attachment is on.  

 
Once that level is turned on the attachment will appear and the dialog reflects that it is on.  
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Updating Levels, Level Filters and Text Styles in Project DGN Files 
Several new levels and level filters have been added with V8i. These are described in later sections of this 
document. Some text styles have been updated as well.  

Take the following steps if you wish to update these in your project MicroStation DGN files using the 
Import Additional V8 Settings tool: 

1. Access the program by choosing the drop down menu option  
T.D.O.T.> V8 – Import Additional Settings  
or from Geopak’s  D&C Manager 
Drafting Standards>Tools > V8 Import 

2. When the command is first started the Import Additional V8 Settings dialog is displayed.  

 
3. Under Import Options, choose which of the V8 additional settings are desired for import. By default 

levels, level filters, text styles and color table are turned on. If you updated your project files with the 
revised color table last year when it was updated you can turn that option off. If not, you may wish to 
leave that option on as well. 

4. Use standard selection methods to highlight the DGN files to be processed. Single click for one file, 
shift key with clicks at each end for groups of files or the control key with clicks to pick various files. To 
un-select a file, hold the control key down and select it again.  

5. When files to be processed have been selected, click 
on the Process Files command button to start the 
import of additional settings. Each file is opened and 
processed.  

If it encounters text styles in use, it will prompt you 
on whether or not to update that style. 

6. When finished a completion message is given. Click 
OK to dismiss the message. 

 
7. Click on the Cancel button to dismiss the dialog.  
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Geopak Roadway Projects 
Old Geopak projects will point to C:\Program Files\GeopakStandards for the file tndot.smd. Since that 
file is now located in C:\Users\Public\Geopak Standards, errors will occur when COGO is started since 
that file cannot be found.  The project’s working directory will also need to be updated if the project moved 
from D: drive to C: drive. 

 
To update a Geopak project: 

1. In the Geopak Project Manager dialog single click on your project file (projectname.prj) and then go to 
the drop down option Projects>Edit. 

2. If your project moved from D: drive to C: drive, change the Working Directory to C:. After reset, you 
can click the Select button for the Job Number to see if it finds the GPK file. 

3. Click on the Preferences button in the Project Info Edit dialog. 

4. In the GEOPAK User Preferences dialog click on the Feature Preferences button. 

5. In the Feature Preferences dialog click on the Select button to specify the location of the SMD file as 
C:\Users\Public\Geopak Standards\tndot.smd.  Once this is set click OK. 
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6. Although not normally set to specific values, you may wish to check COGO Preferences and reset any 
project folder settings that still refer to D: drive. 

 
7. Click on the OK button in the GEOPAK User Preferences dialog and again on the Project Info Edit 

dialog. Your project is now reset. 

Geopak Roadway Projects Working Alignments 
Working alignments build off the Geopak project settings so no further adjustments should be needed once 
the project is reset. 
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Preference file access in Superelevation Runs 
Old Geopak superelevation runs will point to C:\Program Files\GeopakStandards for standard 
superelevation files.  Since these files are now located under C:\Users\Public\Geopak Standards, errors 
will occur when you try to generate the super input file.  

  
To update superelevation runs: 

1. Open your Geopak project and open your first run under Calculate Superelevation. 

2. In the GEOPAK Automated Superelevation dialog go to the drop down option File>Directories. 

3. Click on the Default All button at the bottom of the settings. Preference Files Path, e Files Path and 
Length Files Path will be reset to the correct location C:\Users\Public\Geopak Standards\. 

  
Note:  
These default directory paths are set in the configuration file TDOT.cfg which is normally downloaded 
under C:\Program Files (x86)\Bentley\MicroStation V8i (SELECTseries)\MicroStation 
\config\appl . 

4. Click on the OK button at the bottom to keep the new settings. 

5. Exit the run and click on Yes to save the changes to the run. 

6. Repeat steps 1 through 5 for each superelevation run you have.  
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Criteria file access in Proposed Cross Section Runs 
When you use the Typical function in the proposed cross section dialog the criteria files are copied to your 
project directory and those files should still be found without problems. In special cases you may have used 
the Add button to put in special criteria files from the C:\Program Files\GeopakStandards\criteria 
directory which will no longer be found since those files are not located there. Some examples of this 
situation might be the use of the Berm, Private Drive Profile or Retaining Wall criteria files.  
Most of the time your proposed cross section runs will still function but your cross sections will leave out 
some portion of the proposed section. When you open the run you will get a message such as shown below. 

 
In the output screen when running proposed cross sections and near the top you will see the error message  
Can’t open file C:\Program Files\GeopakStandards\criteria\filename.x as input. 

 
 Take the following steps to update the cross section run: 

1. In the Proposed Cross Sections dialog go to the Shape Clusters section by clicking that option in the 
list on the left. 

2. Click on each roadway cluster in the upper right list box and then review the criteria files listed below 
for the left and/or right sides looking for any place where the criteria file listed in the error message is 
used. In most cases these special criteria files are only used in 1 or 2 locations and you will probably 
know where to look for them. 

3. When you find the criteria file use the Delete button to remove the file from your criteria list and be sure 
and note its position in the criteria list. Click Yes in the message box to confirm the deletion. 

4. Click on the Add button, which will open the Criteria selection dialog. 

5. Click on the directory Select button and go to  
C:\Users\Public\Geopak Standards\criteria. 

6. Click on any criteria file listed and click the OK button. 
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7. Back in the Criteria selection dialog scroll through the list and highlight the criteria file you are 
replacing. 

 
8. Click the To Criteria button to add it back into your criteria file list at the bottom.  

9. Finally use the Up and Down buttons to place the criteria file at the correct location in the list. 

10. Repeat steps 2 through 9 for any other instances of that criteria file or other criteria files not found. You 
can leave the Criteria selection dialog up during this process and if you do, close it, the correct 
directory will still be set when it is re-opened. 

11. Once these corrections are made, exit the run and click on Yes to save the changes to the run. 

In some cases where roadways may have been changed, such as a change from urban to rural,  and the 
criteria files that were no longer needed were deleted from the project folder you may get a missing criteria 
file warning message that it cannot find them even though they are no longer specified for use. 

 

Use Windows Explorer and navigate to C:\Users\Public\Geopak Standards\criteria to copy the missing 
file and then paste it in your project folder. This will prevent the message from popping up every time you 
open the run. You can just click OK until it lets you in the proposed cross section run and it will process 
without issue. 
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Standard file access in Geopak Drainage 
Old Geopak drainage projects will point to C:\Program Files\GeopakStandards for different standard 
files. Since these files are now located under C:\Users\Public\\Geopak Standards …, error messages will 
occur when you open your drainage project since they cannot be found.  If projects were originally on the 
local D: drive, then the move to C: drive may affect some project specific settings as well. 

   
To update the drainage project: 

1. Open your Geopak drainage project. You will get an error message(s) since it cannot certain standard 
files. Click OK to dismiss the message(s). 

2. Under the Drainage drop down menu, go to the drop down option Project>Preferences. 

3. In the Preferences dialog click on the Project Components option in the list on the left. 

4. Reset the location for the Criteria Directory by clicking on the browser icon and going to 
C:\Users\Public\Geopak Standards\criteria\. 

5. Reset the location for the GEOPAK DDB by clicking on the browser icon and going to 
C:\Users\Public\Geopak Standards\tdot.ddb 

  
The Drainage Library and Drainage Cell Library standard files should not need to be reset. In the 
new software, these are now set automatically for you to the correct locations. 

6. Depending on whether or not you have the full path stored with your Superelevation Shapes File and if 
your project moved from D: drive to C: drive, you may need to update that setting. Edit the path or use 
the browse button to reset it. 

7. Click on OK to close the Preferences dialog. 

8. Under the Drainage drop down menu, go to the drop down option Project>Save to save the changes 
just made. 
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Office Links 
Office links such as Excel tabulation blocks are always stored with the full path at the time of linking. If 
your project folder has changed location as in the case of moving from D: drive to C: drive then the links 
will be broken and may require attention. 

If no changes are required then you do not have to do anything. However if you need to update them or 
think they will need to be updated later, you will need to update the Office file location. 

 
To update links: 

1. In MicroStation, go to the drop down option Edit > Links to open the links dialog 
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2. Click the option Change Source on the right side, navigate to the file that is linked and click Open. 

 
The linked file should now be accessible for updating. 

3. Repeat steps 1 & 2 to fix other broken links as needed. 

4. When links are corrected, click Close to exit the Links dialog and double click on the edge of the link in 
MicroStation to ensure they are working correctly. 
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Excel Estimated Roadway Quantities Macros 
Clicking command buttons in old estimated roadway quantities may do nothing or may give an error 
message that the items.dat file cannot be found. They fail because certain aspects of the macros had to be 
changed for use on Windows 7 including the location of Office standard files.  

Other Excel templates such as our auto-build versions may have these types of errors as well but can be 
easily re-generated with the new Windows 7 versions. 

Take the following steps to update your estimated roadway quantities files: 

1. Open the estimated roadway quantities Excel file to be updated. MicroStation should be closed during 
this process.  

2. In Excel, go to File> New> My Templates > TDOT 2nd Sheets and select the Convert Excel To 
V8.xltm template. 

This template was originally created for conversions that were required several years ago but can also be 
used as illustrated here to copy your current data into an updated version of the estimated roadway 
quantities template with revised macros. 

  
3. Select the macro button to Create Excel “Convert to V8” Menu.  This will create a pull down menu 

under the Add-Ins tab on the ribbon named Convert To V8.   
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Close the Convert Excel To V8 file created. 

When the Convert to V8 programs are accessed, it will open Convert Excel To V8.xltm to run the 
convert programs.  Convert Excel To V8.xltm does not need to be saved and should be closed without 
saving after running programs.     

  
4. Click the option Convert Estimated Roadway Quantities File – This program opens a dialog box to 

allow selection of the estimate file to be converted.   

  
The program creates a new Microsoft Office Excel file by copying the information from the existing 
estimated roadway quantities excel file into a new estimated roadway quantities file.  The existing 
estimated roadway quantities file is not changed.  The new file has “_V8" in the filename.   

Excel worksheets that are not named "Col *" will be copied by sheet to the new file but no formatting 
changes will be done to the worksheet.  

After converting the estimated roadway quantities file some additional cleanup may be needed. Use the 
Format Notes Area macro to trim your main quantity blocks and format its footnotes correctly.  

Carefully review all footnotes. They may be getting cut off at the end of the line or at the bottom of the 
note. If the entire note is entered in one cell, adjust the row height so that all lines of the note appear. If 
separate lines of text were entered, you can either combine the text in the first cell or just add any cut off 
words to the next line. Short, single line footnotes should not be affected by this.  

5. Save the new version of your file with _V8 at the end and close all files including the original estimated 
roadway quantities file (without _V8 at end).  

6. Go to Windows Explorer and delete or rename your original file. Rename your new file without the V8 
on the end so that it can be used and recognized from links in MicroStation. 

 



47 

6. MicroStation Tools 

Attributes  
Now includes option to use an element template as well as control for transparency and priority of elements. 

 

  Active Element Template 

 Transparency 

  Priority 

View Tools  
Several of the View Control icons have changed in appearance. They also now include access to View 
Attributes, View Display Mode, View Brightness, Copy View, Clip Volume and Clip Mask.  

 

   View Attributes 

 View Display Mode (new for 2D) 

   View Brightness 

 Window Area 

 Fit View 

  Rotate View 

 Pan 

 Walk (3D only) New! Use to “walk” through 3D Models 

 Clip Volume 

  Clip Mask  New! Similar to Clip Mask for References, can be used as an alternative 
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View Attributes  
This tool has a new layout and view control. Settings are automatically applied to the current view. Options 
to apply to other views are now icons at the top. 

  

 Apply to open views 

 Apply to selected view 

Primary Tools  
Includes some revised icons as well as access to a few new functions.  

 

  Raster Manager 

 Point Clouds     New! Used to display POD point clouds. 

   Saved Views    New access location 

 Auxillary Coordinate Systems New access location 

 Element Information 
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Raster Manager  
Raster Manager now includes several icons for tool access. These are still available through the drop down 
menu and as right click options.  

Several on the fly appearance controls are available on the bottom of the dialog. 

 

  Show Reference Hierarchy 

  Flat Mode 

  New WMS Map, Image 

  Attach Raster, WMS, Image,ECWP 

 Reload  

 Select Raster(s) from View(s)  

 Clip Raster in View  

 Modify Clip  

 Unclip  

 Transform/Modify  

  Move 

  Scale 

  Rotate 

  Mirror 

   Warp 

 Fit Selected Raster(s) to View 

 Fit to Actual Resolution 

 Set Contrast & Brightness 
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Level Display  
The View controls have changed and are now set via icons at the upper left. Also, Dialog Properties is now 
available through an icon on the menu bar.  

 

 Apply to open views 

 Apply to selected view 

Display Colors 
Some do not care for the default level text and level highlight colors for Level Display. These are controlled 
through the same Windows setting. 

Go to the Windows desktop, right click and choose Personalize. Under the Personalization dialog go to 
Window Color at the bottom.  In the Window Color and Appearance dialog, change the Item to Selected 
Items and adjust the color as desired. 
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Element Information  
The appearance of this tool has changed somewhat but works about the same. It uses the selection set tool so 
if anything is selected it automatically displays data for those elements. If nothing is selected then it will be 
blank until you select an element.  

Use the arrow on the right of each data group’s menu bar to open or close them. 

You can change certain attributes of elements from here. If you select any data item it will become a key in 
field for data entry or a drop down box for setting that attribute.  Any changes are immediately done without 
further interaction. 

    

Change Attributes  
The new eye dropper icon at the top is used to match the attributes of any element selected so that you could 
use those settings to change another without changing the current active values. 

The attributes list now includes options to change the transparency and priority of an element.  

It also includes  new items at the bottom to use an active fence, create a new copy of the element with the 
changed attributes or to change all of the colors of an element that includes more than one color setting. 
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Fence Operations 
Fence operations now include dynamic displays so that you can see the results as you do them. 

s 

Measure Distance Perpendicular 
The Measure Distance Perpendicular tool now includes a Segment Only option. If it is off, measurement 
will stop at the end of a line or with line strings and shapes, will jump to the next segment. With Segment 
Only on, the tool locks onto the chosen segment and will let you measure locations beyond the end. 

s 

Change Element Direction or Reverse/Flip Line Style  
This tool now displays a red arrow indicating the current direction. Data point on the red arrow to change 
the direction and data point again to the side to accept the new direction.  
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7. TDOT Roadway Design Division Tools 
Note that with V8i the T.D.O.T. Roadway Design Division  interface is set up separately from the default 
MicroStation interface so to use it , go to MicroStation Manager and set the Interface option at bottom to 
tdot. 

TDOT Design Division Tool Strip 
Access this customized toolbox from the menu bar at T.D.O.T.> Tools> Design Division Tool Strip or 
from Geopak’s  D&C Manager at Drafting Standards> Tools> Design Tool Strip. 

Includes:  
Design Division Toolbox 
Rotate to Horizontal Tools 
Text styles+ 
Custom Line Style Tools 
Graphic Group Lock Toggle 
Plotting Tools 

 
Rotate to Horizontal Tools 
Includes:  
Rotate Element to Horizontal 
Rotate Fence or Selection Set to Horizontal 
Rotate View by Element 

 
Custom Line Style Tools 
Includes:  
Shift Line Style Pattern 
Reverse/Flip Line Style Pattern 
Change Line Style Scale 

 
Plotting Tools 
Includes:  
Iplot, Set 
Set Iplot Default Settings 
InterPlot Organizer  
MicroStation Print 
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Cell Dialogs 
The old MicroStation Cell Tools function and tools have been replaced by customized cell placement tools. 
The default cell placement type varies for different cell dialogs and is set based on the most commonly used 
functionality. 

 
Click on the Cell Placement Type button at the lower left of the cell dialog.  

These are special cell placement tools including: 

Simple Place activates cell and starts MicroStation’s Place Cell command 

Place/Rotate places cell by data point with dynamic rotation  

Place Along places cell along an element at specified spacing, scale and angle 

New dialogs for cell placement control: 

Place/Roate 

 
Place Along 

 
This function works slightly differently than the old MicroStation function. You can pick an element to 
place along at any location along its length for the first identification point and placement will start there. 
The second point tells the tool where to stop placement. 
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Signs 
Sign face cell dialogs include an additional cell placement Place Sign Face with. This replaces the old 
command button used for that purpose and will now place sign face with other optional graphics by default 

Permanent signs now have a label option which can be a sign number or the sign name with size. 

  

Drainage Structure Tools 
All of the old MicroStation Basic programs previously used to place drainage structures in the plan and 
profile have been replaced with new visual basic programs with enhancements. 

Plan – Box Culvert or Bridge 

 
Now includes options to control label and terminator if placed as a flag. During placement structure and text 
label are now shown dynamically. 
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Plan - Endwalls 

  
During placement the structure is shown dynamically, Endwall data including quantities and applicable 
standard drawings are written as Geopak adhoc data to the graphic element for later recall.  

The Review Endwall Data command button opens a secondary dialog for review of all endwall data. 

 
Some of the endwall data can be seen on the fly by simply snapping to the endwall and checking the pop 
up info. 

 
Our set ups for Geopak’s D&C Manager now include pay items for endwall materials which read these 
graphics to get quantities for preliminary estimates. 
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All profile drainage structure tools now include the option to place proposed or existing structures. They 
also have a command button to open the DP station & Elevation tool so that structures may be placed by 
the centerline station and flow line elevation. During Placement structure and text label are shown 
dynamically. 

Profile – Box Culvert or Bridge 

 
Proposed box structures are placed as filled group hole elements for better visibility on the profile. 
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Profile – Slab Culvert or Bridge 

 
Proposed slab structures are placed as filled shape elements for better visibility on the profile. 

 
  



59 

Profile – Pipe 

 
Proposed pipes are placed at a weight of 6 to improve visibility on the profile. 
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Iplot Default Settings 
The listing of settings files is now restricted to leave out the current version of iplot.set as well as settings 
files used only with InterPlot Organizer and not with Iplot. The file list dialog is no longer modal and can 
remain open for later use as needed. Selection of the settings file automatically makes it active with a 
success message which displays on the dialog to indicate the settings file that was activated.  

 

Move Raster by Datum Adjustment Factor 
The user no longer needs to provide a data point for the move. Instead the tool uses the origins of the raster 
file attachments to calculate and give a data point to the system. It now includes a separate command button 
for the Move Raster(s) Back to Original Location function. Also added a command button to open the 
Raster Manager dialog. One or more raster attachments may be moved at the same time now. 

  

DGN Batch Text Editor 
Added Find/Replace Text options Match Case, Whole Words, Use Regular Expressions and Change In 
Cells to duplicate the options provided by the regular tool and give the user the capability to use these as 
needed. All are on by default except for Use Regular Expressions.. 
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Place Mast Arm by Length 
Now includes dynamics when first started so that mast arm is shown at the specified length during 
identification of the start point. 
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8. Geopak Survey 

Survey Project Workflow Toolbox 
A new command button has been added to the Graphics Display group to access the Draw Ancillary 
Features tool which can be used to add underground utility crossings to the profile.  

 

New Survey Level Filters 
Several new level filters have been added for use by Survey.  

The Field Topo level filter is for looking at only field located data without office data showing.  

The Topo Control level filters include associated graphics that are used to control or just to  check a given 
type of survey data. These can be used as needed with other specific level filters when checking survey data.  

Survey - Drainage - Topo Control 
Survey - DTM - Topo Control 
Survey - Field Topo 
Survey - Profile - Topo Control 
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Revised Rockwall Feature 
Only one Survey feature has changed in the SMD database. The rock wall feature named ROCKW now uses 
a new line style that runs along the face of the wall rather than down the center as it did previously. The 
center set up required special consideration in the field and/or post processing in the office when wall center 
points couldn’t be gathered.  

Field Points should be gathered from left to right so that wall will appear correctly when visualized. 

 
WARNING:  
Care should be taken if the need arises to re-visualize data gathered prior to this change since older rock 
walls set up on the wall centerline could be shifted with this new set up.  Re-visualizing will replace the old 
line style ROCK WALL with the new one. If this happens, simply change the line style back to ROCK 
WALL 

Data Acquisition  
Not currently adopted for use by T.D.O.T. Survey.  
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9. Geopak Road 
The Geopak Road training manual for T.D.O.T. Design Division personnel, TDOT GEOPAK Road 
Course Guide.pdf, has been updated for V8i and follows our standard workflows. The locations for 
Geopak tools in that document reflects the use of Civil Workflows as described previously with descriptions 
of the new Task Navigation interface. 

That document, along with the class files, are available from the CADD web page at 
http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/v8design.htm 

Proposed Cross Sections 
The generation of proposed cross sections has not really changed for the user. There are a few small changes 
which should make things run more smoothly than previously. 

Typical Sections 
In the past warning messages would appear when you tried to either apply a roadway typical section on a 
shapeless run or anytime it was about to overwrite standard criteria files in your project folder.  

Our roadway typical sections were set up to handle shapeless runs so that did not matter. Since our criteria is 
standardized and special criteria files have alternate file names that message did not matter either. These 
messages are now suppressed in our configuration of GEOPAK so we no longer have to deal with 
dismissing those warnings all of the time.  

Plot Parameters 
There is a new option under Plot Parameters called Pavement Shapes. This option does need to be turned 
on in your runs for it to place the lines for our pavement superelevation  shapes.  

 
  

http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/v8design.htm
http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/v8design.htm
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Disable View Update 
There is a new cross section processing option named Disable View Update. This is for use on longer 
proposed cross section runs to suppress view updates which can speed up the process substantially. 

    

Plan/Profile Sheets 
New EPSC Level Filters 
We have added 3 new level filters for use in setting up the different Erosion Prevention and Sediment 
Control phases in the plans sheets. 

Sheets - EPSC Clearing and Grubbing 
Sheets - EPSC Intermediate Grading 
Sheets - EPSC Final Construction 

Edit Sheet Number  
We must use the Append Alpha Suffix option now to generate sheets with a suffix letter. The sheet suffix 
letter(s) can no longer be added in Clip Sheets using the Sheet Name Prefix control. 
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Sheet Name Prefix 
The Sheet Name Prefix field is used to control the final format for the DGN filenames which are applied. 
The number of characters used for the sheet number as well as the filename extension can be set.  

Now we enter square brackets with 4 asterisks for the sheet number, [****] , followed by .sht for the 
filename extension. You should end up with [****].sht.  

This differs from the past where we only required 3 asterisks for the sheet number , [***] , followed by a 
suffix letter if needed and  .sht for the filename extension. The Append Alpha Suffix option under Edit 
Sheet Number must be used for the suffix letter. 

 
Refer to chapter 19 in TDOT GEOPAK Road Course Guide.pdf for the plan sheet layout workflow and 
more specific details of its use.  

  



67 

Corridor Modeling & Roadway Designer 
These new functions for Geopak V8i can be used in developing display models of proposed designs for 
presentations at public hearings or other meetings. We have a new template library and style file for use 
with the Geopak V8i Roadway Designer tool in Corridor Modeling. The template library has all of our 
primary roadway types as well as bridges, walls or other associated features. Our MicroStation standards 
include new levels for model displays which already have material assignments so that when models are 
produced they will be automatically rendered as pavement, concrete, grass, etc. 

We are not replacing our current set ups using criteria files for final design. 

Start Corridor Modeling  
Start Corridor Modeling from the roadway model icon in the task root. In the Corridor Modeling dialog we 
will set up the base controls for the corridor project. 

 

 
Import DDB 
Select the DDB option in the list on the left. Our style file is set by default but we do need to import it in. 
Click the Import button to add this control to the corridor project. 
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Click OK in the Import message.  

 
Add Existing Surface 
Next, select the DTM option in the list on the left. The surface type should be set to TIN. Use the browse 
icon to identify your existing ground surface.  

First, click the ADD TIN to List icon on the right. 

Then click Import to add it to the corridor project. 

  
Click OK in the Import message.  
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Set Horizontal & Vertical Alignments 
Now, select the Geometry option in the list on the left. If you have your Geopak Roadway project going, 
the GPK job number should already be set. If not use its browse button to set it. 

Select the proposed roadway centerline chain from the drop down list as well as the corresponding proposed 
profile. 

Use Centerline for the Drafting Standard.  

When all settings are made, click the ADD Chain to List icon on the right. Then click Import to add it to 
the corridor project. 

 
Click OK in the Import message.  

. 

Corridor Modeling creates the folder rddbs where it stores files. The Import functions create those files.  

Open Roadway Designer 
Now that all base controls have been set, we can start the Roadway Designer tool.  Click on the roadway 
model icon in the Corridor Modeling dialog to Open Roadway Designer.  
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When Roadway Designer first opens on a new roadway set up, all views will be blank. The main view to the 
right is a cross section view, the upper left view is the plan view and the lower left is the profile view. These 
include view control icons similar to regular MicroStation views.  

 
Set up a Roadway Corridor 
The first step is to set up a roadway corridor. Click the Manage Corridors icon or go to Corridor > 
Corridor Management.  

Type in a name, set Centerline as 
the Surface Symbology and set the 
Horizontal & Vertical Alignments. 
Some of this may already be defined 
for you. 

Click the Station option and adjust 
the station range as needed for the 
roadway limits.  

Click Add to set up that roadway and 
Close to dismiss the dialog. 

Note that multiple roadways can 
be set up in a single corridor such 
as two roads that form an 
intersection or an interstate 
roadway with ramps and a 
crossroad. 
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Attach a Template 

The next step is to attach a template to the roadway. 
Click the Template Drops icon or go to Corridor > 
Template Drops.  

First set the beginning station value.  

Look through the template library list for the required 
template. Double click the library name if not expanded 
and go to the Templates folder. 

Select the desired roadway template and it will display 
in the preview widow. The multiple slope tie options 
indicate that it is set up for variable slopes such as with 
Case I or Case II as we use them. 

Click Add to set it up in the template drop list and 
Close to dismiss the dialog. 

You can explore the template library to see what all is 
available from the Open Template Library icon in 
Roadway Designer or from Tools> Template Library.  
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Process All 
Now that we have a horizontal and vertical alignment set with a template to use we can process that set up. 
Click Process All to build the roadway through the project. 

  
Using the control buttons on the bottom right, navigate through the cross sections. Notice that the plan and 
profile views are locked with the movement and display a yellow line corresponding to the current cross 
section.  

The lines in the plan view represent the transition lines of various points on the proposed roadway such as 
roadway lanes, shoulders, curb, sidewalks, etc. 

  
You can use the view controls or the mouse scroll button to zoom in and out on the views. 
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Parametric Constraints 
Parametric Constraints are variables that control widths and other values for the template. These are similar 
to Define Variables in Geopak’s Proposed Cross Section tool. Access these from Tools> Parametric 
Constraints. 

  
In the Parametric Constraints dialog click on the Constraint Label drop down to access the individual 
values. These do vary depending on the template but many are commonly used in all roadway set ups. 

 
For this example we will set up a transition at 
the beginning for the shoulder width to go 
from 2’ to 6’ as well as the turn lane to go 
from nothing to 12’. We can also reset the 
subgrade depth to be 1.25’ for the entire 
roadway. 

After selecting a variable, its default value is 
shown. 

Set the Start Value and Stop Value or click 
the lock to make them the same 

Then enter the Start & Stop stations for 
transitioning. Use the begin and end stations to 
apply for the entire roadway. 

Click Add to add the setting to the list.  Click 
Close when done 
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Process Parametric Constraints 
Click Process All again and review the results of the parametric constraint changes. In the plan view we can 
see the beginning transitions. If you zoom in on the cross section view you can observe the change in width 
at various stations of the transition.  

 
Add Additional Templates 
To build up this roadway set up a bit more, we will add a bridge template. Going back to Template Drops, 
we can add additional stations for templates and control whether they try to transition or not. In this example 
we do not want transitioning between the 2 template set ups so the regular template is applied just before the 
beginning and just after the end of the bridge area.  
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Process All again.  

In the plan view we can see that our curb lines are not lining up with the ones on the bridge. This is due to 
the extra 2’ of gutter in addition to the 6’ shoulder. 

  
The bridge template includes separate parametric constraints for elements outside the roadway lanes since 
those can differ from the roadway. We can go back to Parametric Constraints and change the bridge 
shoulders to 8’ to account for the extra 2 feet for the gutter.  

After processing again we can see that our curb lines now line up. 
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Generate Proposed Model 
Before we generate the model we need to go back to the Template Drops dialog. The interval needs to be 
changed at each template set up to 5’ in order to ensure that an accurate proposed model is formed.  

Click Change to apply the edits as you do them. 

  
Click Process All.  

Now we are ready to generate the proposed model. Click on 
the Create Surfaces icon or go to Corridor> Create 
Surface. 

First you need to key in a name for the surface.  

Select the corridor(s) to create the surface from. 

Set General Options as required. Empty Design Surface 
should be on so that when run more than once it will simply 
replace the previous one. 

Under Display in Plan View at the lower left, click on 
Components. 

You will need to be in a 3D DGN file or create a separate 
3D model in your 2D DGN. 

When all settings are made, click Apply. 
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Set View Display 
Fit the 3D view to find your proposed model. Our DGN files are set to display style Wireframe with a 
black background by default. In this view mode you can see the frame work of the proposed model. 

      
Open View Attributes and set the Display Style to Smooth.  

The model may appear dark. Open Adjust View Brightness in the view controls and increase the lighting 
level with the scroll bar provided. 
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The default black background makes it harder to see the model well so you can alter the background used 
with the Smooth display style. Open the Display Style dialog from the view controls and change the 
Background Color to something lighter. 

  
Drive Roadway & Review Model 
Click the Drive Roadway icon in the Corridor Modeling dialog. In the Drive Roadway dialog set the 
driver’s eye location and speed. Click Run to start the drive through. 
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Use MicroStation’s Fit View command after using the Drive Roadway tool to reset the display depth and 
perspective. 

Use view control tools such as Dynamic Rotation or Walk to explore the model. Look for gaps, bad joins 
or other evidence of incorrect model creation. Some of these can be fixed in Roadway Designer or it may be 
simpler to just use MicroStation tools. 

  
All proposed model graphics are created on the following new levels with V8i and are automatically 
rendered with material assignments. 

DESIGN - MODEL - Aggregate 
DESIGN - MODEL - Asphalt 
DESIGN - MODEL - Concrete 
DESIGN - MODEL - Grass 
DESIGN - MODEL - Rip-Rap 
DESIGN - MODEL - Truck Apron Pavers 

Save Roadway Designer & Corridor Modeling Settings 

To save your Roadway Designer set ups for the roadway go 
to File> Save. The file will have an “ird” extension. 

Before closing the Corridor Modeling dialog, save those 
settings as well by going to File> Save. This file will 
have an “rdp” extension. 

FYI 
When proposed models are generated, Geopak TIN and 
InRoads DTM surface files are also created in your 
project folder.  
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10. InterPlot Organizer 
Plotter not found 
As stated previously in this document, InterPlot (Iplot) software requires that plotters must be 
connected to you PC in order to plot to them. This can be an issue in InterPlot Organizer.  

When creating a new plot set for plotting or PDF creation you should always get this message after clicking 
OK in the Create Plots dialog. It indicates that it is applying the settings you specified and that the plotter 
specified is being used. 

 
If you did not get that message, it is a good indication the plotter you asked for was not found. In InterPlot 
Organizer the current default printer is used as shown below. 

 
PDF Generation 
The Export PDF function now includes an option to Create a 
separate PDF file for each plot which can be used when 
generating construction plans.  

At least one user has encountered problems using InterPlot 
Organizer to create PDF files when MicroStation was still open. 
Other users did not appear to have this problem. If you get an error 
in InterPlot Organizer that MicroStation failed during processing 
then close MicroStation and try again. 

They also had problems with a broken Office link. The file would 
print fine but would fail when attempting to create a PDF file. The 
file was no longer available to fix the link so the solution in that 
case was simply to use Break Link at Edit> Links. 
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11. Configurations For Consultant CADD Managers 
The documentation file  TDOT Roadway Design Division V8 Configurations for Consultant CADD 
Managers.pdf has been updated to reflect the changes required for application on Windows 7 with the new 
V8i software. 

That document is available from the CADD internet web page at 
http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/v8design.htm 

In this orientation document, we will present the key files that may need adjustment for application at your 
office. For more information on setting up project level configurations see the document on the web. 

MicroStation & Geopak - TDOT.cfg 
Our configuration file for V8i is very comprehensive since all standards now reside outside the product 
folders. It utilizes variable names for the MicroStation and Geopak standards folders and only has 3 specific 
folder paths specified.  

Default settings in TDOT.cfg: 
#------------------------------------------------------------------------------------------------------------------------------# 
# TDOT.cfg - TDOT Roadway Design Division Standards Configuration File for MicroStation V8i # 
#------------------------------------------------------------------------------------------------------------------------------# 
 
#==============================================# 
# This file sets MicroStation configurations              # 
# for TDOT Roadway Design Division's Use                # 
# Any changes made to this file may prevent access to          # 
# TDOT Roadway Design Division standards.                 # 
#==============================================# 
 
# ___________________________________________ MicroStation ______________________________________________ 
 
 
# TDOT Design Division MicroStation standards folder path 
_TDOT_MICROSTATION_STANDARDS = C:/Users/Public/MicroStation Standards/ 
 
# Special environment settings 
 
# When compressing DGN files, no options on by default 
MS_COMPRESS_OPTIONS  = -ALL 
 
# Include full path in Title Bar 
MS_FULLPATHINTITLEBAR  = 1 
 
# When updating levels do not delete unused levels 
MS_UPDATE_KEEP_UNUSED_LIBRARY_LEVELS = 1 
 
# Setting to allow attachment of large digital image files 
MS_RASTER_LOADMODE  = 3 
 
# Standard folders & files 
 
MS_SYMBRSRC  > $(_TDOT_MICROSTATION_STANDARDS)symb/*.rsc 
 
MS_SEEDFILES      < $(_TDOT_MICROSTATION_STANDARDS)seed/ 
MS_DESIGNMODELSEED  < $(_TDOT_MICROSTATION_STANDARDS)seed/seed2d.dgn 
MS_DESIGNSEED   = $(_TDOT_MICROSTATION_STANDARDS)seed/seed2d.dgn 
 
MS_CELL   < $(_TDOT_MICROSTATION_STANDARDS)cell/ 
MS_CELLLIST   < $(_TDOT_MICROSTATION_STANDARDS)cell/STDS.CEL 
MS_CELL_SEEDFILE   < $(_TDOT_MICROSTATION_STANDARDS)seed/English2dCell.dgn 
 
MS_PLTCFG_PATH  < $(_TDOT_MICROSTATION_STANDARDS)pltcfg/ 

http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/v8design.htm
http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/v8design.htm
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MS_PENTABLE  = $(_TDOT_MICROSTATION_STANDARDS)pltcfg/ 
MS_PLOTDLG_DEF_PENTABLE = $(_TDOT_MICROSTATION_STANDARDS)pltcfg/TdotPlot.tbl 
MS_PENTABLE_DATE_FORMAT=%c 
 
MS_DATA   < $(_TDOT_MICROSTATION_STANDARDS)data/ 
MS_LEVEL_LIB_DIR  < $(_TDOT_MICROSTATION_STANDARDS)data/ 
MS_REMAP_CSVFILE   < $(_TDOT_MICROSTATION_STANDARDS)data/TDOTV8main.csv 
MS_V7TOV8_CSVNAME  = $(_TDOT_MICROSTATION_STANDARDS)dgnlib/TDOTV8mainOnTheFly.csv 
MS_V7_LEVEL_NAME_PREFIX = V7Level 
 
MS_VBASEARCHDIRECTORIES < $(_TDOT_MICROSTATION_STANDARDS)vba/ 
 
MS_TDOTDGNLIB_PATH  = $(_TDOT_MICROSTATION_STANDARDS)dgnlib/ 
 
%lock MS_DESIGNSEED 
 
# ___________________________________________ Geopak ______________________________________________ 
 
 
# TDOT Design Division Geopak standards folder path 
_TDOT_GEOPAK_STANDARDS = C:/Users/Public/Geopak Standards/ 
 
# Geopak resource file folder 
GPK_RSCDIR   = C:/Users/Public/Geopak Resource Files/ 
 
# Force all Geopak configuration variables to supersede RSC file settings 
GPK_FORCE_ALLCFGVARS  = 1 
 
# Setting to create level if not found 
GPK_LEVEL_CREATE_NEW = 0 
 
# Setting to allow Geopak attributes to show with Accusnap 
GPK_ACCUSNAP_IDENTIFY_ELEMENTS_AUTOMATICALLY = 1 
 
# Setting to control station ticks on alignments displayed from D&C Manager 
GPK_DDB_STA_SMALL_TICKS = 0  # ticks left label left 
GPK_DDB_STA_LARGE_TICKS = 2  # ticks both label left 
 
# Suppress warning for shapeless in proposed typical sections 
GPK_TYPICAL_SUPPRESS_SHAPELESS_MODE_VALIDATION_PROMPT = 1 
 
# Suppress warning for criteria file overwrite in proposed typical sections 
GPK_TYPICAL_SUPPRESS_CRITERIA_FILE_OVERWRITE_PROMPT = 1 
 
# Standard folders & files 
 
# Geopak Databases: D&C Manager DDB, Drainage Library, COGO SMD 
GPK_ACBOOK_DDBFILE  < $(_TDOT_GEOPAK_STANDARDS)tdot.ddb 
GPK_DRGPREF_DEFDRLIB  < $(_TDOT_GEOPAK_STANDARDS)TDOTEnglish.dlb 
GPK_SURVMNGR_SMDFILE  < $(_TDOT_GEOPAK_STANDARDS)TNDOT.smd 
 
# COGO Visualization preferences 
GPK_VISUALPREF_SMD  < $(_TDOT_GEOPAK_STANDARDS)TNDOT.smd 
GPK_VISUALPREF_PLOTSCALE = 50.00000 
 
# Superelevation design control files 
GPK_SUPER_PREFDIR  < $(_TDOT_GEOPAK_STANDARDS) 
GPK_SUPER_EDIR   < $(_TDOT_GEOPAK_STANDARDS) 
GPK_SUPER_LENGTHDIR  < $(_TDOT_GEOPAK_STANDARDS) 
 
# Design control file for vertical curves 
GPK_PROFILE_CURVATURE_TABLE  = $(_TDOT_GEOPAK_STANDARDS)tdot01.kvl 
 
# 3PC programs location 
GPK_DC_3PCDIR   < $(_TDOT_GEOPAK_STANDARDS)3PC/ 
 
# XS criteria programs location, typical section controls 
GPK_MY_CRITERIADIR    < $(_TDOT_GEOPAK_STANDARDS)criteria/ 
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GPK_TYPICAL     < $(_TDOT_GEOPAK_STANDARDS)criteria/ 
GPK_TYPICAL_EDITOR    < C:\WINDOWS\system32\write.exe 
 
# Plan & Profile sheet set up library and folder location 
GPK_SHEETCLP_SHEET_LIBRARY_NAME   = $(_TDOT_GEOPAK_STANDARDS)tdot.psl 
GPK_SHEETCLP_SHEET_LIBRARY_DIR    = $(_TDOT_GEOPAK_STANDARDS) 
 
# Geopak Corridor Modeling Databases for Roadway Designer: Template Library and Styles DDB 
GPK_RD_Template_Library  < $(_TDOT_GEOPAK_STANDARDS)TDOTDefault.itl 
GPK_ACBOOK_DDBFILE_STYLES  < $(_TDOT_GEOPAK_STANDARDS)TDOT_Styles.ddb 
 
# default drainage cell library used by Geopak 
GPK_DRGPREF_DEFCELLLIB  < $(_TDOT_MICROSTATION_STANDARDS)cell/STDS.CEL 
 
# Label Style Files 
GPK_LABELER_PLANSTYLEFILE   = $(_TDOT_GEOPAK_STANDARDS)tdotdef_plan.lsf 
GPK_LABELER_XSSTYLEFILE     = $(_TDOT_GEOPAK_STANDARDS)tdotdef_xs.lsf 
GPK_LABELER_PROFSTYLEFILE   = $(_TDOT_GEOPAK_STANDARDS)tdotdef_prof.lsf 
GPK_LABELER_DRGSTYLEFILE    = $(_TDOT_GEOPAK_STANDARDS)tdotdef_drainage.lsf 

Interplot - Iplot.cfg, Iplotsrv.cfg & ip.cfg 

These are software product level configuration files that have been customized for use by T.D.O.T. 
Roadway Design Division personnel. They are rather large files, so listed below each filename are 
configurations of particular interest that may need to be reset for your system. 

Default Folder Location: C:\Program Files (x86)\Common Files\InterPlot\IPLOT\config 

Iplot.cfg 
IPLOT_OUTPUT_DIR = c:\temp 
IPLOT_DLOG_OUTPUT_DIR = c:\temp 
IPLOT_DLOG_SAVE_DIR = c:\temp 
 
IPLOT_COLOR_TABLE_PATH = "C:\Users\Public\MicroStation Standards\data" 
IPLOT_PEN_TABLE_PATH = "C:\Users\Public\InterPlot Standards\Design Scripts" 

Iplotsrv.cfg 
IPLOTSRV_PATTERN_PATH = "C:\Users\Public\InterPlot Standards\resrc" 
 
IPLOTSRV_LINESTYLE_PATH = "C:\Users\Public\InterPlot Standards\resrc" 

Default Folder Location: C:\Program Files (x86)\ProjectWise InterPlot Organizer\config 

ip.cfg 
IP_SETTINGS_PATH = "C:\Users\Public\InterPlot Standards\Settings" 
 
IP_DEFAULT_SETTINGS = iplot.set 
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Hard Coded File Paths 
Although hard coded file paths e avoided wherever possible some standard files will not function correctly 
without being set this way. The following section lists the various standard files grouped by software type 
that have hard coded file paths.   

MicroStation & InterPlot 
Default Folder Location: C:\Users\Public\MicroStation Standards\vba 
IplotSet.mvba  (sett default Iplot settings file)  

This only a concern if you use InterPlot software. 

Access the Set Iplot Default Settings tool through the TDOT drop down menu option Iplot – Default 
Settings or through Geopak’s D&C Manager at Drafting Standards > Tools> Set Iplot. 

 
Open the Visual Basic Editor at Utilities > Macro> Visual Basic Editor 

To edit: 
Navigate to module & subroutine or use the Replace function to find locations 
Make changes as needed 
Click Save icon in Visual Basic Editor 

from form code SelectFiles 
subroutine IplotSettings_Click 
settingsFile = "C:\Users\Public\InterPlot Standards\Settings\" + fileName 

settingsFile = "C:\Users\Public\InterPlot Standards\Settings\" + fileName 

testString = Dir("C:\Users\Public\InterPlot Standards\Settings\iplot.set") 

Kill "C:\Users\Public\InterPlot Standards\Settings\iplot.set" 

FileCopy settingsFile, "C:\Users\Public\InterPlot Standards\Settings\iplot.set" 

from module Start 
subroutine Main 
If FileLen("C:\Program Files (x86)\Common Files\InterPlot\IPLOT\bin\iplot.exe") > 0 Then 

fpath = "C:\Users\Public\InterPlot Standards\Settings" 
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Geopak 
Default Folder Location: C:\Users\Public\Geopak Standards 
DrainageProject.gdf  (default drainage project)  

TDOTdrainageprefs.dpf  (default drainage project preferences)  

Preferences: criteria directory, DDB 

 
Note::  
The Drainage Library and Drainage Cell Library are now set by configuration variables. 

To edit both files: 
Start Geopak Drainage 
Go to Drainage>Project>Open 
Navigate to Geopak  Standards folder and open DrainageProject.gdf 
Go to Drainage>Project>Preferences 
Under Project Components make path changes as needed 
Go to File > Save As 
Navigate to Geopak  Standards folder, select file name TDOTdrainageprefs.dpf and click Save 
Click OK to close Preferences dialog 
Go to Drainage>Project>Save 
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Office (Excel) 
Open the template file and then the Visual Basic Editor at View > Macros> View Macros> Edit 
Note: Due to the many instances of the same folder path in some templates you should use the Replace 
function under Edit>Replace in the Visual Basic Editor as shown below. 

 .  

To edit: 
Navigate to module & subroutine or use the Replace function to find locations 
Make changes as needed 
Click Save icon in Visual Basic Editor 

Default Folder Location: C:\Users\Public\Office Standards\TDOT 2nd Sheets 

Convert Excel To V8.xltm                (Estimated Roadway Quantities.xltm file path, menu control) 
from module ConvertEstimatetoV8 
subroutine ConvertEstToV8 
Workbooks.Add Template:= _ 
“C:\Users\Public\Office Standards\TDOT 2nd Sheets\Estimated Roadway Quantities.xltm" 

MsgBox "File " + Chr(34) + _ 
"C:\Users\Public\Office Standards\TDOT 2nd Sheets\Estimated Roadway Quantities.xltm" + _ 

from module ConvertMenu 
subroutine CreateConvertMenu 
 .OnAction = "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Convert Excel To V8.xltm!ProcessSelection" 

Estimated Roadway Quantities.xltm,  (Items.dat file path, auto build calls in Roadway only) 
Bridge Quantities.xltm,  
Maintenance Quantities.xltm 
from form code SearchForText 
subroutine UserForm_Initialize 
 Open "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat" For Input Shared As #1 

from module AutoBuildCalls 
subroutine BuildGRBlock 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Guardrail Tab Builder.xltm", , True 

subroutine runcheckitemsGR 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Guardrail Tab Builder.xltm", , True 
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subroutine BuildStormDrainagePipes 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Pipe Tab Builder.xltm", , 
True 

subroutine runcheckitemsSS 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Pipe Tab Builder.xltm", , 
True 

subroutine BuildCatchBasinsBlock 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Structure Tab Builder.xltm", 
, True 

subroutine runcheckitemsCB 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Structure Tab Builder.xltm", 
, True 

from module datfilchecks 
subroutine CheckforDat 
Open "C:\Users\Public\Office Standards\tdot 2nd Sheets\Items.dat" For Input Shared As #1 

datdate = FileDateTime("C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat") 

subroutine checkforTxt 
Open "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" For Input Shared As #1 

txtdate = FileDateTime("C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt") 

subroutine dattxt 
FileCopy "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt", "C:\Users\Public\Office Standards\tdot 2nd 
Sheets\Items.dat" 
Kill "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" 

Kill "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" 

subroutine DateCheck 
datdate = FileDateTime("C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\Items.dat") 

subroutine netDownload 
msg2 = "C:\Users\Public\Office Standards\tdot 2nd Sheets" 

subroutine TxtCopy 
FileCopy "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt", "C:\Users\Public\Office Standards\tdot 2nd 
Sheets\Items.dat" 
Kill "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" 

from module FillIn_Items 
subroutine FillinItemNos 
Open "C:\Users\Public\Office Standards\tdot 2nd Sheets\Items.dat" For Input Shared As #1 

Default Folder Location: C:\Users\Public\Office Standards\TDOT English Tab Quantities 

Guardrail Tab Builder.xltm,    (Items.dat file path) 
from module ItemNumbersCheck 
subroutine checkitemsGR 
filespec = "C:\Users\Public\Office Standards\TDOT 2nd Sheets\items.dat" 
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m2 = "at C:\Users\Public\Office Standards\TDOT 2nd Sheets" 

datdate = FileDateTime("C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat") 

ifile = "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat" 
Open "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat" For Input Shared As #1 

Storm Drainage Pipe Tab Builder.xltm,   (Items.dat file path) 
from module CheckItemsDat 
subroutine checkitemsSS 
filespec = "C:\Users\Public\Office Standards\TDOT 2nd Sheets\items.dat" 

m2 = "at C:\Users\Public\Office Standards\TDOT 2nd Sheets" 

datdate = FileDateTime("C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat") 

Open "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat" For Input Shared As #1 

Storm Drainage Structure Tab Builder.xltm,   (Items.dat file path) 
from module ItemNumbersCheck 
subroutine checkitemsCB 
filespec = "C:\Users\Public\Office Standards\TDOT 2nd Sheets\items.dat" 

m2 = "at C:\Users\Public\Office Standards\TDOT 2nd Sheets" 

datdate = FileDateTime("C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat") 

Open "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat" For Input Shared As #1 

Default Folder Location: C:\Users\Public\Office Standards\Survey 

Survey_Contact_Acq_Create.xltm  (ROWAcqTable.xltm, help & letter template file paths) 
from Microsoft Excel Objects code Sheet1 (Project Info) 
subroutine cmdAcqTable_Click 
strPath = "C:\Users\Public\Office Standards\Survey\" + "ROWAcqTable.xltm" 

subroutine cmdHelp_Click 
 FName = "C:\Users\Public\Office Standards\Survey\Survey Contact Letter and R.O.W. Acquisition Table Creator.pdf" 

from form code Letter 
subroutine cmdCreateLetter_Click 
 strLetterPath = "C:\Users\Public\Office Standards\Survey\" 
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