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2nd Sheets Using Office 2010 and MicroStation V8i 
General Information 

Instructions in this document are for development of 2nd sheets using Office 2010 and MicroStation V8i.  

The process of attaching Office files in MicroStation is called ‘OLE linking’, which stands for Object Link and 

Embed. It works best to Link Excel files and to Embed Word files when users are attaching Office files to 

MicroStation. CADD Support has embedded several Word documents in MicroStation DGN seed files including 

General Notes and Index sheets in order to streamline their production.  

‘Embedded’ Word documents are available only from inside the MicroStation file.  

‘Linked’ Excel files are external to MicroStation and can be opened & edited from either inside 

MicroStation or outside of MicroStation directly in Excel. If the Office file is edited separately from 

MicroStation, the link in MicroStation must be updated after the MicroStation file is opened in order to 

reflect the current information.  

The Office OLE attachment is a picture of the Office file. The boundary of the picture is defined by a 

MicroStation shape element. The OLE attachment can be modified by graphics commands such as move, 

copy and scale.  
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Set up Office 2010 

This is the recommended set up for Office 2010 when using the T.D.O.T. Roadway Design Division templates 

and programs. If Office templates are not installed to the default folders, then the directions will need to be 

modified accordingly. 

Do this one time only when using Word and Excel 2010 for the first time with the TDOT templates and 

programs. This must be done for each user profile in the computer that will be using Office 2010 to link with 

MicroStation. 

 

Word: 

1. In Word 2010, click on the File tab at the far left of the ribbon and choose Options from the drop down list. 
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2. In the Word Options dialog click on Save in the options on the left.  

Set the Save Files in this format: option to ʺWord Document (*.docx)ʺ. 
Set the Default file location: Use the Browse button to the right of ʺDefault File Location:ʺ   
Set the folder where you wish all Word documents to be saved by default. 
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3. In the Word Options dialog, click on Advanced in the options on the left.  

Scroll down to the General section and click the File Locations button. 

 

 
 

Click on User Templates and then click on the Modify button.  
Navigate to and set the folder to: 

ʺC:\Users\Public\Office Standardsʺ.  

 

Click OK to save the setting.  

 

 

 

 

 

This will set the default template location for both Word 
and Excel so that the TDOT template folders will be 

available.  
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4. In the Word Options dialog, click on Trust Center in the options on the left. 

  Click on the Trust Center Settings button. 
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5. In the Trust Center dialog, click on Trusted Locations in the options on the left. Then modify as listed: 

a. If you will be using Office documents on a network drive, check the box at the bottom for  

Allow Trusted Locations on my network. 

b. Select the trusted location for ʺWord 2010 default location: User Templatesʺ. 

Click the Modify button. 

 
All files stored under Trusted Locations will automatically load macros without any action from the user. 

 
c. In the dialog box, which opens for the User Templates, set the Path by Clicking on the Browse 

button.  
Select the Path ʺC:\Users\Public\Office Standardsʺ.  
Select on the box for ʺSubfolders of this location are also trustedʺ and click OK. 
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6. In the Trust Center dialog, click the Add new location button. 

 

 
Click the Browse button and navigate to the location where your project files are stored.  

It is recommended for TDOT personnel that all Roadway Design Projects be stored on your c: drive in a folder 

named Projects and individual projects in subfolders. 
Click on the ʺSubfolders of this location are also trustedʺ option, key in a description if desired and  

click OK.  

 
 

 

With your project folders defined as trusted locations, all macros will automatically be enabled.  
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Your Trusted Locations should look like this. 

  
 

If you open a Word 2010 file with macros that is not in a trusted location, the following two settings, numbers 7  

and 8 will provide you the opportunity to enable the macros as needed. 
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7. In the Trust Center dialog, click on Macro Settings in the options on the left.  

The option ʺDisable all macros with notificationʺ should be set.  

 
8. In the Trust Center dialog, click on Message Bar in the options on the left. 

The option ʺShow the Message Bar in all applications when active content, such as ActiveX controls 
and macros, has been blockedʺ should be set.   

 

 
 

 

9. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings just made. 

 

10. This completes the settings under Word Options, so click the OK button at the bottom of that dialog to 

complete the Word 2010 set up.  
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Word Template Files 
T.D.O.T. Roadway Design Division Word templates used with MicroStation, are part of the Standard Design 

and Survey CADD Files and Documents, Office downloads from the TDOT CADD web page. The templates 

listed below should be in their default folder locations as shown.   

 

C:\Users\Public\Office Standards\Survey 
• Property Owner Contact Letter - Aerial Flagging.dotm 

• Property Owner Contact Letter - Geotechnical Staking.dotm 

• Property Owner Contact Letter - ROW Staking.dotm 

• Property Owner Contact Letter - Survey.dotm 

• Region 1 Survey Letterhead.dotx 

• Region 3 Survey and Roadway Design Letterhead.dotx 

• Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX.dotx 

• Survey Check List_Field.dotx 

• Survey Check List_Office.dotx 

• SURVEY_SUBMITTAL_CHECK_LIST.dotx 

• SuveyContact_Avery5160_Labels.docx 

• SuveyContact_Envelopes.docx 

C:\Users\Public\Office Standards\TDOT 2nd Sheets 
• Bridge Index.dotx 

• CONSTRUCTION INDEX XXXXXX.dotx 

• Drop Off Notes Traffic Control XXXXXX.dotx 

• EPSC Notes XXXXXX.dotx 

• General Notes XXXXXX.dotx 

• Index and Standard Drawings XXXXXX.dotx 

• PRELIMINARY INDEX TITLE SHEET XXXXXX.dotx 

• RIGHT OF WAY INDEX TITLE SHEET XXXXXX.dotx 

• Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX.dotx 

• SHEET FORMAT FOR 2ND SHEET NOTES XXXXXX.dotx 

• Special Notes XXXXXX.dotx 

• Standard Roadway Drawings XXXXXX.dotx 

• Standard Structure Drawings XXXXXX.dotx 

• Standard Traffic Operations and Structure Drawings XXXXXX.dotx 

• Standard Traffic Operations Drawings XXXXXX.dotx

C:\Users\Public\Office Standards\TDOT Tab Quantities 
-NONE- 
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Excel: 

1. In Excel 2010, click the File tab at the far left of the ribbon and choose Options from the drop down list. 

 
2. In the Excel Options dialog, click Save in the options on the left.  

Set the option for Save Files in this format:  ʺExcel Workbook (*.xlsx)ʺ. 

Change the path given for Default File Location:  
Set the folder where all Excel documents should be saved by default.  
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3. In the Excel Options dialog, click Trust Center in the options on the left. 

Click the Trust Center Settings button.  

 
 

4. In the Trust Center dialog, click Trusted Locations in the options on the left.  

Select the trusted location for Excel 2010 default locations: User Templates.  

Click the Modify button. 

 
All files stored under Trusted Locations will automatically load macros without any action from the user. 
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5. In the dialog box, which opens for the User Templates, set the Path by clicking the Browse button.  

Select the Path ʺC:\Users\Public\Office Standardsʺ. 

Select the box for ʺSubfolders of this location are also trustedʺ and click OK. 
 

 
 

6. In the Trust Center dialog box, click on the Add new location button. 
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Click on the Browse button and navigate to the location where your project files are stored. It is 

recommended for TDOT personal that all Roadway Design Projects be stored on your c: drive in a folder 

named Projects and individual projects in subfolders. 
Click on the ʺSubfolders of this location are also trustedʺ option, key in a description if desired and  

click OK.  

 
With your project folders defined as trusted locations, all macros will automatically be enabled. 

 

Your Trusted Locations should look like this. 

  
Note: If you open an Excel 2010 file with macros that is not in a trusted location, the following two settings, 

numbers 7 and 8 will provide you the opportunity to enable the macros as needed. 
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7. In the Trust Center dialog box, click on Macro Settings in the options on the left.  

The option ʺDisable all macros with notificationʺ should be set.  
 

 
8. In the Trust Center dialog box, click on Message Bar in the options on the left. The option ʺShow the 

Message Bar in all applications when active content, such as ActiveX controls or macros, has been 
blockedʺ should be set.  

 

 
 

9. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings just made. 

 

10. This completes the settings under Excel Options, so click the OK button at the bottom of that dialog to 

complete the Excel 2010 set up.  
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Saving Documents with Macros 
If you try to save a new document that has macros with the default file formats, .docx or .xlsx, then you will 

be warned that all macros will be thrown out since those file types are specifically macro free. 

 

 

 

 

 

 

 

 

If you no longer need the macros, simply click Yes to save the file in the macro free format.  Otherwise, 

click No to stop at this point. 

 

 

To keep macros for later use, go to File > Save As  

and under Save As Type choose the macro-enabled one. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Previously saved documents automatically save in their current format. 
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Enabling macros that are not in a trusted location 
If you open a file with macros that is not in a trusted location, a Security Warning message bar will appear. 

 
 

If you need to use the macros, click the Enable Content button in the message bar. The Security Warning 

message bar goes away and macros are ready for use.  Once a document has been trusted, Office 2010 

remembers the name so that it will not be necessary to Enable Content again later.  
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Excel Template Files 

T.D.O.T. Roadway Design Division Excel templates used with MicroStation, are part of the Standard Design 

and Survey CADD Files and Documents, Office downloads from the TDOT CADD web page. The templates 

listed below should be in their default folder locations as shown. 

 

C:\Users\Public\Office Standards\Survey 
• ROWAcqTable.xltm 

• Survey_Contact_Acq_Create.xltm 

• Survey Weekly Progress Report.xltx 

• Utility Owners.xltx 

C:\Users\Public\Office Standards\TDOT 2nd Sheets 
• Bridge Quantities.xltm 

• Maintenance Quantities.xltm 

• Project Commitments.xltx 

• Estimated Roadway Quantities XXXXXX.xltm 

C:\Users\Public\Office Standards\TDOT Tab Quantities 
• Builder Guardrail Tab.xltm 

• Builder Storm Drainage Pipe Tab.xltm 

• Builder Storm Drainage Structure Tab.xltm 

• OutFalls.xltx 
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Estimated Roadway Quantities Excel File 

The Estimated Roadway Quantities Excel file is required on all jobs per the T.D.O.T. Roadway Design 

Division Roadway Design Guidelines. A preliminary construction quantity estimate Excel file shall be submitted 

to the Estimating and Bid Analysis Office when the Right-of-Way plans are turned in per Section 3-400.15. A 

complete construction quantity estimate Excel file shall be turned in to the Estimating and Bid Analysis Office 

when the plans are turned in for construction, Section 4-140.06. See Section 4-140.05 for details on the 

Estimated Roadway Quantities Excel file.  

 

This Excel quantities file is used as an input file for a T.D.O.T. computer database program. The 

worksheets names, column and row locations and heading information should not be changed or the database 

program will not input the data correctly.   

 

The Estimated Roadway Quantity Excel file will contain all worksheets that are needed for a design project. 

The following worksheets are required but not limited to the following: Project Data, Rdwy Quantity Block 1, 
Rdwy Quantity Block 2 (if needed, etc), Foot Notes, Box Bridge Quantities Block, and all Tabulated 
Quantity Blocks. There may be many worksheets for a large job. 

 

The Estimated Roadway Quantity file has all of the approved Tabulated Quantity Blocks embedded in it for 

TDOT Roadway Projects. 

 

Structures, Maintenance and the Right-Of-Way Utilities Office also have estimated quantities Excel files 

that they submit to the Estimating and Bid Analysis Office. The templates for these are included in the TDOT 
2nd Sheets download.  

 

The Utility Office provides their estimated quantities Excel worksheet to their users. The Utility Office will 

send a copy of the utility Excel worksheet to the Roadway Design Division so the “Estimated Utilities 

Quantities” Sheet 2A3 for the plans can be produced, as per Section 4-137.00 in the T.D.O.T. Roadway 

Design Division, Roadway Design Guidelines. 

 

Save the Excel file to your project folder. Any links attached will not be correct if the Excel file is not saved 

onto your computer or computer network where your files are stored before attaching them to a MicroStation 

file.  
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Create The TDOT Estimated Roadway Quantities  

It is required that the user have all of the tabulated quantity blocks in the same file with the estimated roadway 

quantities. By putting all of the worksheets together in the same Excel file, the quantities on the different tab 

block sheet quantities should be linked to the estimated quantities sheet. These same tab blocks and quantity 

blocks will be linked to the MicroStation design files. By setting up the Excel estimate file in this way, each 

quantity can be entered and updated in one location only, and will then be updated in each of the locations 

where the value appears.  

These directions will first demonstrate creating the Estimated Roadway Quantities file and later describe 

adding other tabulated blocks. 

1. In Excel, click on the File tab on the far left of the Excel ribbon and choose New 
2. Under New, choose My Templates. 
 

 

 

 

 

 

 

 

 
 
 
 

3. Go to the TDOT 2nd Sheets tab and select the Estimated Roadway Quantities.xltm template 

 

 

 

 

 

 

Choose the file 
with the latest 
revision date. 
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4. Fill in the Project Data sheet. Instruction notes are available on the worksheet. Hold the mouse pointer 

over the small red triangles for directions. NOTE the rows with RED text (2, 3, 5, 6, 9, 11, 13, 27, 28 and 

31) in column “A” are required be filed in before you can proceed! The example below shows what must be 

filled in to proceed 

 
 

 

 

 

5. When you have filled in all the data for the Project Data sheet click on the Continue Button. 

You will notice the sheet tabs will appear at the bottom of the sheet. 
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6. Before you can fill in the Estimated Roadway Quantity Block(s) you must have quantities and they must be 

tabulated. All tabulated blocks are in this one file. To open a tabulated block sheet click on the tab at the 

bottom named Add Sheets. 

 
 

 

7. This will bring up a dialog box so the user can choose the Classification and Type of Tab Block need. 

NOTE: All approved Tabulation Blocks are in this file and are hidden. This will unhide them for you. 

For this example, we will open Catch Basins & Manholes Tabulation Block. 

  

 

Classification 
Type 

 

 

 

 

 

 Make your selection and Click Select. 
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8. This will open a sheet for the chosen Tab Block as shown. 

 
 

Then the user can fill in the data that is need and repeat step no. 7 as many times need to open the Tab 

Blocks that are required for project. 

  

NOTE:  If you need to remove a Tab Block, repeat step no. 7 and choose the same Tab Block again, and 

click on Select, and it will be hidden again. 

 

 In all Tabulated Blocks, the Headers are locked and cannot be edited. 

 Individual cells for things like item numbers and type can be edited, as required.  

 The Tab Blocks are setup for a full sheet of data when placed in a MicroStation file.  

 You may delete Rows as needed to adjust the size (length) of the block. 

 Be careful not to delete the TOTALS Row so the sheet will tabulate your quantities. 
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9. The worksheets named: Rdwy. Quantity Block 1, Rdwy. Quantity Block 2 and Box Bridge Quantities 
Block, contain several macros that are available to help fill out the estimated quantities block. On these 

worksheets, buttons are provided to access the macros with descriptions to the right as shown. 
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Estimated Roadway Quantities Macros 

Macro: 
Project Column Format  
These macros listed below will Hide and Unhide the extra quantity columns. These macros should always be 
used so that the macro buttons and description text to the right will move with the columns and keep the 

correct format of the table. Micro ʺ1 Project Column Formatʺ thru ʺ5 Project Column Formatʺ function the 

same they just open up the additional columns as needed. 

One Project Column Format  
For most projects, where there is only one project number, the one column format should be used and 

it is the default table as shown and when the Excel file is open for the first time.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: If the one column format is not shown and you need only one column then Click on the 

ʺ1 Project Column Formatʺ button and the Macro will reformat the sheet. 
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Two Project Column Format  
For projects that go across two counties or for another reason have two project numbers with a total 
uantities column, there is the two column format. Click on the ʺ2 Project Column Formatʺ button and 
the Macro will reformat the sheet. 

 
 
 

 

 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

Project Column Formatting for 3 thru 5 Column Format 
For projects that go across three counties or for another reason have three project numbers with a total 
quantities column, there is the three-column format thru five-column format. Click on the ʺ3 Project 
Column Formatʺ button thru ʺ3 Project Column Formatʺ button and the Macro will reformat the 
sheet. 

 
 

Note:  You can Click on the Project Column Format Buttons at any time to Hide or Unhide the columns as 
needed. But it will nor remove any information you will need to do the manually.    
Do not hide unrequired data! This will cause problems for other users. 
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Macro: 
Select Item Numbers From List  

Note:  There are two macros to place item numbers in the work sheets:  
The first is the macro ʺSelect Item Numbers From Listʺ and it uses the Items.dat file. 

  The file Items.dat must be in the folder C:\Users\Public\Office Standards\TDOT 2nd Sheets.  
The second is the macro ʺImport CSV File for Items.ʺ 
These macros are used to fill in item numbers, descriptions and units.  
They will direct the user to the website to download the items.dat file  
if the file is not on the computer in the correct location or 
if it is more than 30 days old. 

 

1. Uses the Items.dat file located at C:\Users\Public\Office Standards\TDOT 2nd Sheets to find items,  
list them in an Item Select window and write the items selected to the worksheet.  

 

 
If the items.dat file is not on the computer in the correct location or if it is more than 30 days old you 

will see the following block and you will need to down load the items.dat file. It is recommended to always 

update this file due to item numbers and descriptions changing so often due to standard drawings being 

revised. 

 

2. Click on ʺSelect Item Numbers From Listʺ  
This will open a dialog box named: ʺOld Database Fileʺ as shown. 

 

 

 

 

 

 

3. Click on ʺDownload Items.dat from the web page now.ʺ 
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4. The following web page will open. In the web page named; ʺRoadway Item Listʺ scroll down the blue 

underlined text ʺDownload Search Item listsʺ and click on it. 
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5. This will open Windows Explore to RUN an EXE file named ʺRosdwayItemList.exeʺ,  Double Click on it.  

 

 

 

 

 

 

 

 

 

 

 

6. This will open a dialog box named: ʺWinZip Self-Extractor – RoadwayItemList.exeʺ as shown. 

 

                                                                                                                                   Then Click Unzip 

 

Check Overwrite files without prompting 

 

 

 

 

This will place the Items.dat file in the right place and overwrite the old file. You can X out of this box. 

 

 

 

7. You should see the following dialog box if the macro works correctly. 

 

Click OK 

 

 

 

 

 

 

 

Now you are ready to search and import item numbers in the Estimated Roadway Quantities Block. 

 

31 

 



Macro: 
Placing Select Item Numbers & Descriptions In The Roadway Quantity Block 
 

1. You will need to Click on ʺSelect Item Numbers From Listʺ Again to be able to select item numbers. 

 
 

2. You will see the following Dialog box again but now Click on ʺUse existing Items.dat file.ʺ 

 

 

 

 

 

 

 
 
This will bring up the Item Select Dialog Box. 
 
These are the associated buttons: 
 
Search – If the Search for Items field is left blank, the search button will open all of the items. Put in one or 

more numbers or letters to pull up all items containing those characters. Do not use any wild card 

characters. Use the Shift or Ctrl key to select or unselect multiple items.  

 
Import –  Prompts for the Excel cell to start placing the selected item numbers, descriptions and units.  

 
Reset –  Clears the Items Found list box. 

 
Close –  Closes the Item Select dialog box. 
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3. The Item Select Dialog Box  

For this example, we typed 705 in the ʺSearch For Itemsʺ window and clicked on Search. 

This will bring all items numbers that stars with 705.            Then we select the desired items. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Click Import. 
This will bring up a dialog box that will ask you for a starting location of the cells to placing the item data. 

 

 

 

 

 

5.  Click in the Estimated Roadway Quantities block cell where we want to start placing the item numbers we 

choose. In the example we selcted B6. 

         

 

 

 

 

 

 

 

 

 

 

33 

 



The imported Item data 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

Macro: 
Fill In Description and Unit  
Uses the Items.dat file located at C:\Users\Public\Office Standards\TDOT 2nd Sheets to find items,  
list them in an Item Select window and write the items selected to the worksheet. The macro ʺFill In 
Description and Unitʺ functions like the macro ʺSelect Item Numbers From Listʺ But only imports one 
item number at a time and you must know the complete item number.  
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Macro: 
Import CSV File for Items  

GEOPAK produces quantity calculation files in CSV (comma-separated values) format that can be inputted 

directly into the Excel estimated roadway quantities file. The default CSV file format from GEOPAK is item 

number, GEOPAK description, units and quantity.  This macro imports only the item number and the quantity 

and then uses the Fill In Description … macro to enter the description and unit. The GEOPAK descriptions do 

not always match the official item descriptions, which must be used. 

1. You are prompted for the 

location of CSV file to import.  
 

Find your file to import, click 

on it then click on open. 

 

 

 

 

 

 

 

 

This will bring up a dialog box that will ask you for a starting 

location of the cells to place the item data. 
   

2. Then Click  

in the Estimated 

Roadway Quantities 

block cell where we 

want to start placing 

the item data we 

choose. Then Click 

OK. In the example we 

selcted B6. 
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The imported Item data 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

To import a CSV file as written for other tabulated quantity worksheets, see macro Import CSV. 
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Macro: 
Sort Item Numbers  

The item numbers must be sorted in numerical order by the item number. This macro sorts the item 

numbers selected by the user and maintains the correct formatting. The macro prompts the user to select the 

items to be sorted by the cell range in column B. Notice in the figure below; the item numbers are out of order.  

 

1. Click on ʺSort Item Numbers.ʺ  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This Brings up the dialog box to select the range for sorting. 
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2. Select the range to be sorted by highlighting the Estimated Roadway Quantities Block in column B. 

For this example, we highlighted B6 thru B20 and it fills in the Select Sort Area dialog box. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Click OK 
Notice the item numbers are now sorted.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

After sorting, the blank lines at the bottom can be deleted and blank lines between groups can be inserted as 

desired. Select the row by the row number, and right click for row Delete and Insert tools. 
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Macro: 
Format Item Numbers  
The borders, text sizes, text justification, fonts, etc. may be changed as the estimate table is being filled in as 

shown. This macro reformats the estimated quantities block to the original size and proper format. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 

1. Click on ʺFormat Item Numbersʺ. Notice the table is now formatted correctly. 
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2. Once the table is reformatted, it brings up the dialog box to save the changes.  

If the table looks ok, Click Yes to save the Excel file. 

 

 

 

 

 

 

 

 

 

Macro: 
Import CSV  
This macro brings in a CSV (comma separated values) file to the worksheet selected, starting at the cell 

selected. This is intended as a way to build tabulation blocks on other worksheets, but can be used to bring the 

CSV file in without having any processing done on the information to the Estimated Roadway Quantities Block.  

You are First prompted for the CSV file to import. For this example, we did ROW Markers.  
 

       Select the worksheet & cell location. 

 

 

 

 

 

 

 

 

 

 

                      Before Import                   After Import  
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Auto-Build Tabulated Quantity Block Macro Access 

These macros are provided as a way to access the macros in the Excel auto-build tabulated quantity block 

templates. When those templates are inserted as worksheet templates, their macros are not brought in. The 

macro buttons can be re-assigned to these macros to access the programs from the original template files.   

BuildCatchBasinsBlock     runcheckitemsCB 

BuildGRBlock        runcheckitemsGR 

BuildStormDrainagePipes    runcheckitemsSS 

See the section Auto-Build Tabulated Quantity Blocks for full descriptions of these macros.   

 

Alternate Pay Items  

All alternate items must be placed after all of the other roadway items.  

In Column C (the description column) on the line preceding the alternate items, enter the designation for the 

alternate as ALTERNATE AA1, ALTERNATE AA2, ALTERNATE AA3, etc.  
AA1 will alternate with AA2 and AA3.  

If there were another set of items to be alternated, they would be labeled ALTERNATE AB1, ALTERNATE 
AB2, ALTERNATE AB3, etc.  

AB1 will alternate with AB2 and AB3.  

A third set of alternates would be AC1, AC2, AC3, etc. 
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Additional Estimated Roadway Quantities Worksheets 

To add an additional ʺRdwy. Quantity Block #ʺ Worksheet: 

1. Select the worksheet tab named ʺAdd Sheets.ʺ  

 
 
 
 
 
 
 
 
 
 
 
This will bring up a dialog box so the user can choose the Classification and Type of Tab Block need. 

NOTE: All approved Tabulation Blocks are in this file and are hidden. This will unhide them for you. 

For this example, we opened Roadway Quantities Blocks & Rdwy. Quantity Block 3. 

  

 

Classification 
Type 

 

2. Make your selection and Click Select. 

 

Your New Worksheet 
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Note: 

The Project Data worksheet must be the first worksheet in the file, the second set of worksheets are the 

Estimated Roadway Quantities worksheets with the name Rdwy. Quantity Block # (numbered 1 thru 6 if 

needed), the third set is the Foot Notes worksheet and the fourth set is the Box Bridge Quantities worksheet 

and the next set is all other tabulated worksheets need for the roadway project. 

 

Add Tabulated Quantity Blocks In The Estimate File 

Note: On all tabulated quantity sheets, the TOTALS row of cells contain formulas to sum the contents of the 

columns or rows. 

 

1. Select the worksheet tab named ʺAdd Sheets.ʺ  

 
 
 
 
 
 
 
 
 
 
 
This will bring up a dialog box so the user can choose the Classification and Type of Tab Block need. 

NOTE: All approved Tabulation Blocks are in this file and are hidden. This will unhide them for you. 

 

 

For this example, we opened Storm Drains & Endwalls & Storm Drain Endwalls. 

  

 

Classification 
Type 

 

2. Make your selection and Click Select. 
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Your New Worksheet 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

Note:  The new worksheet selected may not be in the proper order. To change the order of the 

worksheets, select the worksheet tab, hold the left mouse button down and then drag and drop to 

the location wanted.   
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Removing Tabulated Quantity Blocks In The Estimate File 

Note: To remove a tabulated quantity sheet that you have opened just repeat the process for opening the 

sheet. This process will hide the worksheet but will not remove any data you have entered into it.  Do NOT 

submit an Estimated File with hidden data it will not work properly for the Estimate and Construction Offices. 

They will send your file back to you to fix. 

 

1. Select the worksheet tab named ʺAdd Sheets.ʺ  

 
 
 
 
 
 
 
 
 
 
 
This will bring up a dialog box so the user can choose the Classification and Type of Tab Block that need to 

be hidden \ removed. You must choose the exact name of the Tabulation Block for this to work. If you have 

renamed a tab for a Tabulation Block, it will not work. 

 

Classification 
Type 

 

2. Make your selection and Click Select. 
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Your Worksheet Is Now Hidden 
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Standard Tabulated Quantity Template Formatting 

1. All fonts are Arial. 
2. Body text is size 9 or 10, not bold. 

3. The main heading text is size 16, bold. 

4. The sub heading text is size 9 or 10, bold.  

5. The TOTALS text is size 12, bold. 
6. The body horizontal lines are light weight. 

7. The heading borders and vertical lines are medium weight. 

8. All justification for cells is preset.  
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Auto-Build Tabulated Quantity Blocks 

The following Excel templates include macros that automatically build the tabulation blocks using data files 

generated by GEOPAK. 

Guardrail Tab Builder.xltm  

Storm Drainage Pipe Tab Builder.xltm 

Storm Drainage Structure Tab Builder.xltm  

 

Guardrail Tab Builder 
The macro in template Guardrail Tab Builder.xltm builds the guardrail block from a guardrail output file 

created with GEOPAK’s Design & Computation Manager Pay Items. The macro also runs the Check Items 
Numbers program to verify all item numbers that are used.  See the GEOPAK Road Course Guide, D&C 
Manager – Additional Functions, Section 20c. Quantities for directions to create the guardrail output file 

using the Comp Book format. An example is shown below. 

 
Do not use the Append function in GEOPAK to add guardrail quantities from multiple roadways together in 

the same file. Instead, generate each roadway guardrail tabulation in separate files and then combine using 

any text editor. The Append function uses line feeds that are not recognized by Excel and will cause this 
program to fail. 
 

In Excel, click the Build Guardrail Block button and the user is given a file open dialog to Select GEOPAK 
Guardrail Pay Items Output File. Once the file is identified, the macro reads the data and builds the block. 
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Different roadways are sorted alphabetically based on the roadway chain name from the output file. 

If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file then it will be 

necessary to re-assign the macros for the buttons. Select a location away from the macro button, right click 

over the button and choose the Assign Macro option. From the macro list, pick BuildGRBlock for the top 

button & click OK to finish. Assign runcheckitemsGR to the bottom button. If you do not see these macros 

listed in your estimated roadway quantities file, then you will have to either set it up in a file by itself or update 

your estimated roadway quantities Excel file to the latest version of that file which includes these macros. 
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Storm Drainage Pipe Tab Builder 
The macro in template Storm Drainage Pipe Tab Builder.xltm builds the storm drainage pipe tabulation 

block from the drainage report file created with GEOPAK Drainage using the drainage report format file 

TDOTlinksFULL.drf. The macro also runs the Check Items Numbers program to verify all item numbers, 

which are used. 

In Excel, click the Build Storm Drainage Pipe Block button to activate the file open dialog to Select 
Storm Drainage Link Report File. Once the file is identified, the macro reads the data and builds the block. 

 
If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file then it will be 

necessary to re-assign the macros for the buttons. Select a location away from the macro button, right click 

over the button and choose the Assign Macro option. From the macro list, pick BuildStormDrainagePipes 

for the top button & click OK to finish. Assign runcheckitemsSS to the bottom button. If you do not see these 

macros listed in your estimated roadway quantities file, then you will have to either set it up in a file by itself or 

update your estimated roadway quantities Excel file to the latest version of that file which includes these 

macros. 
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Storm Drainage Structures Tab Builder 
The macro in template Storm Drainage Structure Tab Builder.xltm builds the storm drainage catch 

basins, junction boxes and manholes tabulation block from the drainage report file created with GEOPAK 
Drainage using the drainage report format file TDOTnodesFULL.drf. The macro also runs the Check Items 
Numbers program to verify all item numbers that are used. 

In Excel, click the Build Catch Basins and Manholes Block button and the user is given a file open 

dialog to Select Storm Drainage Node Report File. Once the file is identified, the macro reads the data and 

builds the block. 

 
If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file then it will be 

necessary to re-assign the macros for the buttons. Select a location away from the macro button, right click 

over the button and choose the Assign Macro option. From the macro list, pick BuildCatchBasinsBlock for 

the top button & click OK to finish. Assign runcheckitemsCB to the bottom button. If you do not see these 

macros listed in your estimated roadway quantities file, then you will have to either set it up in a file by itself or 

update your estimated roadway quantities Excel file to the latest version of that file which includes these 

macros. 
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Link Tabulated Quantity Blocks to Estimated Roadway Quantities Worksheet 

To link cells from tabulated quantity block worksheets to the estimated roadway quantities worksheet: 

1. Select the cell where the linked value will be displayed. Enter the equal sign, = 

For this example we will link item no. 709-05.06, MACHINED RIP-RAP (CLASS A-1). 

 
 

2. Click to the worksheet and cell to be linked.  
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3. Then add an + in the Formula Bar (if you are going to link another tabulation block) and  

click on the second worksheet and cell to be linked. 

 
4. When the correct worksheet name and cell address are entered into the Formula Bar entry window,  

click on the check mark,  on the Formula Bar and the total quantity will be linked as shown. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note:  Do not have quantities linked to values in separate workbooks.  

The Estimating and Bid Analysis Office will not accept files with links to separate Excel files.  
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 MicroStation 2d Files for Word and Excel 

Have a 2d design file ready with a sheet border placed in it or open the plans sheet MicroStation DGN file. 

As with most design files for T.D.O.T. projects, the design file should be created from the T.D.O.T. Roadway 

Design Division Seed2d.dgn seed file, which is part of the T.D.O.T. Roadway Design Division standard CADD 

files downloads.    

Name the MicroStation DGN sheet file according to CADDV8.pdf , Section Roadway Design DGN Project 
Filenames; Standard Sheet File Types: for all sheet files Use .SHT extension. For example, use the name 

002A.sht for the first ESTIMATED ROADWAY QUANTITIES MicroStation sheet file and the second 

002A1.sht etc. Tabulated Block sheets use the name 002B.sht, 002B1.sht, 002B2.sht, etc. For the 

complete INDEX of all sheets see the Roadway Design Guidelines. 

There are several reasons why the MicroStation DGN sheet files need to be named according to the 

Standard Sheet File naming requirements. One, the project will be very easy to plot using InterPlot Organizer 

where the sheets will automatically be in order. Two, the names of the sheet files must be the same as the 

sheet number so that when the sheet is published on FileNet, other divisions, such as Right-of-Way and 

Construction, can easily find and use the files produced by the Design Division. 

All Second Sheet files must be on a 1:1 scale! The Traffic Control and EPSC Tabulation Blocks shall 

also be placed on a 1:1 scale. The Right-Of-Way Acquisition Table should be on a 1:1 scale if it is on a 

sheet by itself or if it is with a Property Map it should be placed at the scale of the property Map. Other links 

can be placed on a plan sheet at the scale of the sheet or at the scale listed in the tabulated block. 

 

Creating a New Second Sheet 
1. Open MicroStation SS2 and click on the New File Icon. 
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2. In the window that opens to create a new 2nd sheet you need to set the seed type to seed2d.dgn. If it is not 

set, click Browse and select it. Next, set the location where the file will be created. Select your project 

Folder where the file is to be placed. It should be placed with the rest of the project files. The last thing you 

need to set is the name of the file. Then click Save. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. In the window that opens select the file and click OPEN. 
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4. When the MicroStation file opens, the first thing the user needs to do is set the active scale to 1:1 for 

second sheets. In the Menu Ribbon at the top of MicroStation select Utilities and dropdown to Key-in and 

click on it to open it.  Key in as=1,1,1 in Key-in window and hit Enter. The file will be set to a 1:1 scale if it 

is a 2D or 3D file. Then in the Menu Ribbon at the top of MicroStation select File and dropdown to Save 
Settings and click on it. This will save the active scale so you will not need to do it again for this file. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Now we place a sheet cell. In the Menu Ribbon at the top of MicroStation, select T.D.O.T., and pull down to 

Sheet Cells and click on it.  
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6. This will bring up a dialog box to select your sheet border. Click on, Plan for Tabulated Quantities.  

 

 

 

 

 

 

 

 

 

 

7. This will activate the sheet cell the user needs to place the cell in the MicroStation file by clicking in the 

MicroStation view window where they want to place the cell. The sheet cell should look like this. 

 
 

The sheet cell has snap points for placing the Estimated Roadway Quantity blocks by corners. The 

Yellow snaps points are for placing the quantity block on the left side of the sheet. The first snap point is for 

placing the beginning corner point of the block and the second is ending corner point. The third, fourth, fifth 

and sixth snap points are provided if the quantity file has more than one column for quantities. The Purple 

snap points can be used for a second Estimated Roadway Quantity block with one column of quantities or 

for placing the Foot Notes by corners. The Blue snap points are the maximum limits for any Excel or 

Word file being attached by corners. 
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Excel Linking to a MicroStation File 

Linking The Estimated Roadway Quantities Block 
1. Open your Estimated Roadway Quantity file. For this example, we will use the Rdwy. Quantity Block 1. 

All tab blocks have been setup so the top row and the row just below the table is one cell each, to make it 

easy for selecting. Select the information in Excel needed for linking to the MicroStation file. Click on the 

row above the block and hold down the Shift key then click on the row just below the table (in this 

example it is row 1 and 67). This will select an extra row and column on each side of the block to provide a 

border on each table. The selected area should now be highlighted.  

2. Right click on your mouse and pick Copy from the choices given. This puts the selected information into 

the Windows Clipboard. 
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3. In your MicroStation file on the menu bar, go to Edit > Paste Special…  
(The Excel link will be placed on the active level in MicroStation) 

 
Select the Linked Microsoft Excel Worksheet option and click the Paste button, 

 

 

 

 

 

 

 

 

 

 

 

 

4. Select the Method: By Corners. 

 

 

 

 

 

 

 

5. Snap to the left Yellow snap point then second Yellow  

Snap point and the Rdwy. Quantity Block 1  
is placed on the sheet in your DGN file. 

 

You now have a live Excel file linked to your DGN  

file so when you make changes in your Excel file  

they can be updated without attaching the file again. 
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Linking The Foot Noes 
6. Open your Estimated Roadway Quantity file. For this example, we will use the Foot Notes. All tab blocks 

have been setup so the top row and the row just below the table is one cell each, to make it easy for 

selecting. Select the information in Excel needed for linking to the MicroStation file. Click on the row above 

the block and hold down the Shift key then click on the row just below the table (in this example it is row 1 

and 67). This will select an extra row and column on each side of the block to provide a border on each 

table. The selected area should now be highlighted. 

7. Right click on your mouse and pick Copy from the choices given. This puts the selected information into 

the Windows Clipboard. 
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8. In your MicroStation file on the menu bar, go to Edit > Paste Special…  
(The Excel link will be placed on the active level in MicroStation) 

 
Select the Linked Microsoft Excel Worksheet option and click the Paste button, 

 

 

 

 

 

 

 

 

 

 

 

 

9. Select the Method: By Corners. 

 

 

 

 

 

 

 

10. Snap to the left Purple snap point then second Purple  

Snap point and the Foot Notes are placed on the 

sheet. 

 

Again you have a live Excel file linked to your DGN  

file so when you make changes in your Excel file  

they can be updated without attaching the file again.  

61 

 



Linking The Tabulated Quantities Blocks 
 

11. Open your Estimated Roadway Quantity file. For this example, we will use the STORM DRAIN 
ENDWALLS Tabulation Block. All tab blocks have been setup so the top row and the row just below the 

table is one cell each, to make it easy for selecting. Select the information in Excel needed for linking to the 

MicroStation file. Click on the row above the block and hold down the Shift key then click on the row just 

below the table (in this example it is row 1 and 61). This will select an extra row and column on each side 

of the block to provide a border on each table. The selected area should now be highlighted. 

 

12. Right click on your mouse and pick Copy from the choices given. This puts the selected information into 

the Windows Clipboard. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

13. In your MicroStation file on the menu bar,  
go to Edit > Paste Special…  

 
Select the Linked Microsoft Excel Worksheet 
Option and click the Paste button, 
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14. Select the Method: By Size. 

Click on Rotate With View. 

Set the Scale to: 18.  
 

  

 

 

 

 

 

 

All Tabulation Blocks are set up to be placed on a scale of 18.  

The Active Scale and the Sheet file in the DGN file must be on a 1 to 1 scale. 

 

 

 

 

 

15. Place the Tabulated Block anywhere inside the sheet 

border in the DGN file by clicking with your mouse 

that now has the Tab Block attached to it.  

 

 

 

 

16. You will need to move the Tab Block you just attached 

to the top left corner of the sheet. You must save and 

close your Excel file to be able to move the attach file in 

MicroStation. Snap to the top left corner of the attached 

tab block to pick it up and Snap on the Blue Snap 
Point in the top left corner of she sheet file as shown to 

have the block in the right location of the sheet. 

 

Again you have a live Excel file linked to your DGN file 

so when you make changes in your Excel file  

they can be updated without attaching the file again.  
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Linking Multiple Blocks To One Sheet 
 

All Tabulated Quantity Blocks are set up for a full sheet for each block. In most small jobs, you will not need 

a full sheet of most tables. All Tabulated Block have been set up so the user can delete the rows needed to 

be removed to make the table the size it needs to be. The Rows for the Headers are locked so they cannot 

be deleted, but the Row for the TOTALS is not locked, so do not delete this Row or the table will not 

tabulate your quantities. 

 

Note: It is ok to have one Tabulated Block per sheet in the design project, but if there is a need to place 

multiple blocks on one sheet then repeat steps 11 thru 16 to have the blocks placed in upper left corner at 

the Blue Snap Point.   

 

17. In this example, we have attached two blocks to the Blue Snap Point in the upper left corner of the sheet. 

The two blocks have been edited by removing the rows we do not need (rows 9 thru 54) in our blocks. The 

user will need to move the blocks off the top of each other. In MicroStation activate AccuDraw, click on 

Move element, then snap to the left top corner of one of the blocks and move down in the sheet. It is 

recommended to keep one half inch between blocks. Your sheet should look something like this example. 

 

 

 

If your Tabulation Block extends 

into the area under the 4 inches 

under the Project ID Block in the 

upper right corner than something 

did not attach correctly. 

 

It is recommended that each time a 

Tabulation Block is attached in a 

MicroStation file that the user 

compress design, save settings, exit 

completely out of MicroStation and 

reopen it before attaching another 

Excel or Word file.  
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Excel Text Size in a MicroStation File 
 

All text in the Estimated Roadway Quantity file that has the Tabulated Quantity Blocks is based on the Arial 

font and the blocks are set to be placed at a Scale 18. This should produce a text size values for .14 for the 

rows in the middle of all tab blocks that are to be filled in. This is the recommended text size for the best 

legibility in the plans. 

 

The Arial font, text size 9 in an Excel Tab Block when placed at a scale 18 will measure in the DGN file a 

height of .14 feet. 

 
1-scale size sheet, set the scale to 18 for placement: 

Main Body text size 9 in Excel will measure 0.14 feet in MicroStation  

Table Name text size 16 in Excel will measure 0.24 feet in MicroStation 

Total Row text size 12 in Excel will measure 0.18 feet in MicroStation 

 

50-scale size sheet, set the scale to 900 for placement: 

Main Body text size 9 in Excel will measure 7 feet in MicroStation  

Table Name text size 16 in Excel will measure 12 feet in MicroStation 

Total Row text size 12 in Excel will measure 9 feet in MicroStation 

 

Because the Excel file link is attached as a picture, the text cannot be measured directly. Zoom in and 

use the measure tool to see if the body (not the headings) text is approximately the correct size. 
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Open & Update the Excel OLE Attachment 
The changes made to the Excel files outside of MicroStation will not be changed in MicroStation until the Excel 

links have been opened & updated.  

Use one of the following methods:  

1. In MicroStation, start the Element Selection tool and double click on the link to be revised. The Excel file 

is opened. Make any changes that may be needed and save the file. The link is updated in MicroStation.  

2. In MicroStation, go to Edit > Links… In the Links dialog, select the link to be revised and click Open 
Source. The Excel file is opened. Make any changes that may be needed and save the file. The link is 

updated in MicroStation.  

You should not use the Update Now option in the Links dialog without opening the document first. The link may 

be updated but errors are generated and you may corrupt your MicroStation file. 

3. In MicroStation, select the link to be revised and the Worksheet Object tools are enabled. Go to Edit > 
Macro-Enabled Worksheet Object > Edit. The Excel file is opened make any changes that may be 

needed and save the file. The link is updated in MicroStation. 

4. Open all linked files in Excel. In MicroStation, go to Edit > Update Links.  
This function should update all of the links in the file without opening the links. When used with Office 2010, 

errors are generated and nothing may be updated. 

 

Relinking 
When the sizes of the rows are changed, the area linked will still be displayed in MicroStation but will be 

warped or truncated. It will need to be relinked to correct the display in graphics. 

To relink an Excel file: 

1. Move the existing linked graphics away from the sheet border. 

2. Open the Excel file. 

3. Follow the directions for a new link. See section Excel Linking to MicroStation. 
4. After the new link has been established and is correct, the link graphics from the old link can be 

deleted. 
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Word Embedded in MicroStation 

Word Documents Embedded in MicroStation DGN Seed Files 

There are MicroStation design seed files set up for the 2nd sheets with the T.D.O.T. Word documents 

embedded. These seed files have sheet borders set up at a one-scale. 

MicroStation seed files with embedded Word documents: 

• BLANK SHEET FOR 2ND SHEET NOTES XXXXXX.dgn 

• Drop Off Notes Traffic Control XXXXXX.dgn 

• EPSC Notes XXXXXX.dgn 

• General Notes XXXXXX.dgn 

• Index and Standard Drawings XXXXXX.dgn 

• Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX.dgn 

• Special Notes XXXXXX.dgn 

• Standard Roadway Drawings XXXXXX.dgn 

• Standard Structure Drawings XXXXXX.dgn 

• Standard Traffic Operations and Structure Drawings XXXXXX.dgn 

• Standard Traffic Operations Drawings XXXXXX.dgn 
 

Creating a Second Sheet from a Seed File in MicroStation 
1. From MicroStation or MicroStation manager,  

Go to File > New in MicroStation or click the New File icon in MicroStation Manager …, and in the 

project folder, Browse to select the seed file needed for the sheet, assign the name according to TDOT 

CADD’s sheet nameing conventions and assign a *.sht extension. See CADDV8.pdf, Section 

Standard Filenames, part Standard Sheet File Types: (Use .SHT extension). For example, use the 

name 001A.sht for the seed file named Index and Standard Drawings xxxxxx.dgn. Be sure to look 

for the latest date at the end of the file name for each seed file used. 

There are several reasons why the MicroStation DGN sheet files need to be named according to 

the Standard Sheet File naming recommendations. One, the project will be very easy to plot using 

InterPlot Organizer where the sheets will automatically be in order. Two, the names of the sheet files 

must be the same as the sheet number so that when the sheet is published on FileNet, other divisions, 

such as Right-of-Way and Construction, can easily find and use the files produced by the Design 

Division. 

The OLE link is displayed as a ‘picture’ of the Word document. It has a shape around the edge. The OLE 

link can be copied, moved or scaled using the graphics commands.  
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Seed file Editing Notes: 
  
1. In MicroStation, use the Element Selection tool and double click on the embedded Word document. The 

embedded document will open in Word. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Note that the Word document header says Document in DesignFileName.sht. Make edits as needed. 

 

3. Occasionally information previously deleted needs to be added back into the Word document. This can be 

accomplished by cutting and pasting from other open Word documents. To open a temporary General 

Notes or Index and Standard Drawings file in Word, go to the File tab at the far left of the ribbon and 

choose New > My Templates >TDOT 2nd Sheets > General Notes_xxxxxx.dotx or Index and Standard 
Drawings xxxxxx.dotx (The file you need info from). Cut from the temporary document and paste to the 

document in the sheet file. Close the temporary document without saving them.   

In General Notes documents, each section is numbered starting at 1 (one). If the 1st note in a section is 

deleted, the remaining notes will pick up the numbering sequence from the previous section. To correct 

this, highlight the first note in the section, right click and choose the option Restart at 1.  

 

4. After making the edits wanted, go to the File tab at the upper left and choose Save or click on the Save 

icon at the upper left. Changes made in the Word document will not be shown in MicroStation until the 

Word document is closed. 

 

5. The only access to an embedded document is from the graphics in the MicroStation design file. If the 

graphic display of the embedded Word document is deleted, the Word document will be deleted. If 
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MicroStation has not been closed and the file has not been compressed then the graphics and the Word 

document can be recovered through the Undo command.  

 For this reason, it is recommended that a copy of the Word file information be made after significant 

edits have been done.  

This can be done several ways. In the Word document, go to the File tab at the upper left and select 

Save As to make a copy to the project folder. In MicroStation, the OLE link graphics can be copied to the 

side creating separate OLE link of the edits at that moment which creates an additional separate 

embedded Word document. Of course, a backup copy of the entire MicroStation DGN file can be made. 

 

Special Info in the Word Header & Text Body  
 The Header: 

There is special text in RED, which is the latest Updated Date for this file and the Instructional 

Bulletin(s) that the file was updated to their requirements. 

There is special text in Black, which list the Effective Date for the data in the word file.  

There is special text in Blue, which is special instruction of the user. 

The Body of Text: 
There is special text in Blue, which is special instruction of the user. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

More than one Sheet Needed 
If more than one plan sheet will be needed for General Notes or Index sheets: 
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1. Make edits as needed to the Word document embedded in the first sheet and close the Word document. 

Since the text is not easily moved from one MicroStation design file to another, it is recommended 

that all of the edits be made to the first MicroStation General Notes or Index design file before 

creating the additional sheets. 
2. Repeat step 1 under section Creating a Second Sheet from a Seed File in MicroStation as listed below. 

From MicroStation or MicroStation manager,  

Go to File > New in MicroStation or click the New File icon in MicroStation Manager …, and in the 

project folder, Browse to select the seed file needed for the sheet, assign the name according to the 

sheet name directions and assign a *.sht extension. See CADDV8.pdf, Section Standard Filenames, 

part Standard Sheet File Types: (Use .SHT extension). For example, use the name 001A1.sht for 

the second sheet of the seed file named Index and Standard Drawings xxxxxx.dgn. Be sure to look 

for the latest date at the end of the file name for each seed file used. 

 

3. In the new MicroStation sheet file, edit the Word document. Highlight all of the text (except the heading if 

needed) on the first page in the Word document and delete it. Save & close the Word document to see the 

changes in the MicroStation file.  

 

4. Repeat as needed for additional sheets.  

 

  

70 

 

https://www.tn.gov/content/dam/tn/tdot/roadway-design/documents/cadd_files/documents/CADDV8.pdf


Embedding Word Documents in Existing MicroStation DGN Sheet Files 
Sometimes you need to add small groups of notes to existing plan sheets in MicroStation.  

This section describes the process of embedding the Word documents in MicroStation.  
The TDOT Word documents embedded in the MicroStation seed files are also available as Word templates. 
These can be used to add notes or standard drawings back into full sheets as needed.  

 

T.D.O.T. Roadway Design Division Word templates used with MicroStation at  

C:\Users\Public\Office Standards\TDOT 2nd Sheets: 

• BLANK SHEET FOR 2ND SHEET NOTES XXXXXX.dotx 

• Drop Off Notes Traffic Control XXXXXX. dotx 

• EPSC Notes XXXXXX. dotx 

• General Notes XXXXXX. dotx 

• Index and Standard Drawings XXXXXX. dotx 

• Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX. dotx 

• Special Notes XXXXXX. dotx 

• Standard Roadway Drawings XXXXXX. dotx 

• Standard Structure Drawings XXXXXX. dotx 

• Standard Traffic Operations and Structure Drawings XXXXXX. dotx 

• Standard Traffic Operations Drawings XXXXXX. Dotx 

 

A Full Sheet of Notes
   

1. In Word, go to the File tab at the upper left, choose New > My Templates > TDOT 2nd Sheets, and select 

the type note file needed. (Or use your own note files) 

(Note: if you use a non TDOT 2nd  Sheet template the following scales for the sheets will not be correct.) 

 

2. Edit the notes as needed. Select and copy to put the text into the Windows Clipboard. 
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3. In your MicroStation file on the menu bar,  
go to Edit > Paste Special…  

 
 
 
 

Select the Embedded Microsoft Word Document 
Option and click the Paste button. 

 

 

4. If you are placing a Full Sheet of Notes in a Second Sheet 

that is 1:1 scale then you should use a Sheet Border that 

has the Snaps Points at the top of the sheet. 

 

Select the Method: By Corners. 

Click on Rotate With View. 

   
 
 

                                                                                                                                

5. Place the Word Note File by clicking with your mouse on the Snap Points at the top of the Sheet File. 
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Text Size for a Full Sheet of Text 
Arial font is the standard Font, text size 7 for normal text in Word (font and size in TDOT templates): 

1-scale size sheet: 

Text Size 13 for .14 text size  -   this will measure 0.14 feet in MicroStation  

and will measure 0.14 inch on the printed sheet 

Text Size 11 for .12 text size 

Text Size 9 for .10 text size  

50-scale size sheet, multiply the dimension above by 50: 

Text Size 650 for .14 text size 

Text Size 550 for .12 text size 

Text Size 450 for .10 text size 
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Placing a Word File on a Layout Sheet 
   

1. In Word, Select and copy your Text into the Windows 

Clipboard that you want to place in the DGN file. 

 

2. In your MicroStation file on the menu bar,  
go to Edit > Paste Special…  
Select the Embedded Microsoft Word Document 
Option and click the Paste button. 

 

 
3. Select Paste as: Embedded and Method: By Size.  

Under the extra options, click on Rotate With View. 

 

 

 

 

 

 

 

4. Set the Scale Size. The following only works if the text is Arial and 7 point size in the Word document.  

This is what the TDOT Standard Note size is based on.  

If the DGN sheet scale is 1:1 than set the scale to 38.  

If the DGN sheet scale is 50:1 than set the scale to 1900.  

 

 

 

 

 

5. Data point at the 

location on the DGN 

file where the Word 

file is to be placed.  
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6. Use MicroStation’s Move Element command to position the link as needed. The temporary Word 

document used to copy the notes from can be closed without saving since the document is now embedded 

in the MicroStation DGN file. 

 

Additional Notes concerning this method of Embedding 

The By Corners method is used for Word documents to ensure that the text comes in at the correct 

size. The By Scale method does not yield consistent results when used with Word attachments. That 

method is used with Excel attachments. 

Because the embedded Word file is attached as a picture, the text cannot be measured directly. 

Zoom in and use the measure tool to see if the body (not the headings) text is approximately the correct 

size. 
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Open & Update the Word OLE Attachment 

Embedded Word Documents 
In MicroStation, start the Element Selection tool and double click on the document to be revised. The Word 

file is opened. Make any changes that may be needed and save the file. The document is updated in 

MicroStation.  

Linked Word Documents  
Linking Word 2010 documents instead of embedding them is not recommended due to several compatibility 

issues between Word 2010 and older versions of MicroStation. Any made with Office 2010 will have to 

consider the following if it is necessary to open & update them in MicroStation versions prior to MicroStation 

V8i including MicroStation V8 2004. 

Word 2010 documents linked to MicroStation cannot be opened from inside MicroStation and they cannot be 

updated until they are open in Word.  

In order to update these after being linked, you must first open the document through Word 2010. After making 

any needed edits, save the file and then with it open in Word, use one of the following methods to update what 

appears in MicroStation. 

1. In MicroStation, go to Edit > Links… In the Links dialog, select the link to be updated and click Update 
Now.   

2. In MicroStation, go to Edit > Update Links.  
To use this method, it will be necessary to open all linked files first.  

It should update all of the links in the file without opening the links but when used with Office 2010 without the 

files open, errors are generated and nothing is updated. 
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Correcting Overlapping Text from Embedded Word Documents 
With previous versions of Office and MicroStation when the height of the text area in the embedded Word 

document was reduced from what it was when originally set up, then the text became warped causing text 

characters to overlap. This could occur when more than one plan sheet is needed and the last sheet does not 

have full text columns or perhaps in a case where you have less than one full sheet and the columns are 

adjusted to be the same height. It could also happen if after you have added a small set of notes, one or two 

are removed.  

This problem appears to be corrected with Office 2010 and MicroStation V8i.  If you are using MicroStation V8 

2004 then you may still run into it.  

Take the following steps to re-embed the document and correct this problem:  

1. After edits are done to the embedded Word document, the text becomes warped and overlaps in 

MicroStation. 

2. Open the document and in Word go to the Office button at the upper left and select Save Copy As… to 

save the document outside the MicroStation DGN file to your project folder. 

3. Open the Word document from your project folder, select and copy to put the text into the Windows 

Clipboard. 

4. In MicroStation, delete the original embedded document or move it to the side off the sheet. 

5. The OLE attachment will be placed on the active level, reset as desired. 
6. In MicroStation, go to Edit > Paste Special…, select the Embedded Microsoft Office Word Document option 

and click the Paste button. 

7. Select Paste as: Embedded and Method: By Corners. Under the extra options, click on Rotate With View. 

8. Data point at the location where the upper left corner of the data needs to start on the sheet. This sets the 

first corner and you are prompted to Select Rectangle Corner. 
9. In the MicroStation keyin field enter the required dx= keyin to set the corner across from the first point.  

The scale of the plan sheet as the width dimension of the document inside of Word determine the 

dimension used in this keyin. General Notes and Index sheets are set up as full sheets in Word at 11” X 

17” and in MicroStation at a scale of 1 so you should use dx=26 for them. Refer to the table of values in the 

previous section for use when embedding Word documents in MicroStation. 

After re-embedding … 
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Formatting Word Documents 

The Office 2010 interface includes a series of tab options across the top, each of which displays a “ribbon” of 

command options. As you expand or shrink the width of the Office window, these commands are adjusted to 

show less or more. You can right click over the top of the ribbon to minimize it when not in use if desired. 

 
When you right click from text in your document, some quick formatting tools are shown above the regular right 

click option list. 
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Show/Hide Formatting 
The Word documents created for TDOT plans production contain special formatting so they will appear 

correctly on the plan sheets. Text styles, tabs, bullets and numbering, paragraph indents, hanging indents, 

columns, column breaks, page breaks and more are used. These are non-printing characters and do not show 

in the normal view in Word. In order to edit the Word documents successfully, it is often helpful to see these 

formatting characters.  

To display the formatting characters, use the Show/Hide display command. It is located on the Office 2010 

ribbon under the Home tab in the Paragraph section. It appears as a paragraph mark.  

Click on the Home tab. Look at the Paragraph section of the ribbon and click on the Paragraph mark to 

Show/Hide formatting characters. 

 
 

Clicking the paragraph mark will toggle off and on the display of the formatting characters. When it is toggled 

on, we can see section breaks, paragraph marks, tabs, etc. 

 

  

79 

 



Text Styles in Word 
A text style will set all of the characteristics for the specified text. This includes font, font size, tabs, indents, 

color, heading, bullets and numbering, etc. There are text styles for each type of text used in the TDOT 2nd 

sheet Office templates. These text styles all start with V8. 

Text style controls can be found on the Word 2010 ribbon under the Home tab in the Styles section.  

Word 2010 includes a type of style control called Quick Styles. When you move your cursor mark over the 

quick style it temporarily applies that style to the entire paragraph where your typing insertion point is currently 

located. In the example below, I was in the first note and it dynamically shows what it would look like with the 

style Heading 1 applied to it. To apply the style permanently, left click on your mouse. 
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Click the arrow with the line above it at the bottom of the Quick Styles scroll bar to see all of the quick styles 

currently available.  

 
 

There are two ways to access the standard TDOT 2nd sheet text styles. You can click on the Apply Styles 

option, which appears at the bottom of the Quick Styles drop down menu shown above. This opens up the 

Apply Styles dialog. You could also click the small square with the arrow in it at the lower right of the Styles 

section title bar. This opens up the Styles list. 
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Indents, Hanging Indents, Line Spacing, Tabs, etc. 
To see the indents, hanging indents, tabs, etc. put the cursor at the text/paragraph in question, right click and 

select Paragraph. Note that the Tabs can be accessed at the lower left of the dialog. To change any of these 

settings, select the text to be changed, go to the Paragraph dialog and make the changes as needed. 

You can also access the Paragraph dialog on the Office 2010 ribbon under the Home tab in the Paragraph 

section. Click the small square with the arrow in it at the lower right of the Paragraph section title bar. 

    
Indent & Spacing controls can also be found on the Office 2010 ribbon under the Page Layout tab in its 

Paragraph section. 
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Numbering & Bullets 
You can access Numbering and Bullets on the Office 2010 ribbon under the Home tab in the Paragraph 

section. Click either of these to use the current active format or click the arrow next to them to pull out the drop 

down menu for them. From the drop down menus choose Define New Number Format or Define New Bullet 
to set up a new format. 

    

 
 

 

 

 

Position yourself in a given numbered paragraph and right click for various numbering controls. 
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Page Setup 
You can access Page Setup on the Office 2010 ribbon under the Page Layout tab. The Page Setup section 

includes controls for the margins, orientation, size and columns of the page. 

 
The TDOT General Notes and Index & Standard Drawings templates have a paper size of 11” x 17” and use a 

landscape orientation. 
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Columns 
You can also access Column formatting controls in the Page Setup section on the Office 2010 ribbon under 

the Page Layout tab.  

The TDOT General Notes and Index & Standard Drawings templates are set up into three columns. The 

number of columns and justification can be set from the Column drop down menu. 

 
To set widths and other column settings, select the More Columns option from the drop down menu to open 

the Columns dialog. 
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Breaks 
You can also access the Break controls in the Page Setup section on the Office 2010 ribbon under the Page 
Layout tab.  

Turn the Show / Hide formatting display on to see page, column and section breaks. Use the Delete key to 

remove a break. Use the drop down menu from Breaks in the Page Setup section to insert a page, column or 

section break as needed. 

 
 

 

You can also insert a Page Break from the Pages section on the Office 2010 ribbon under the Insert tab.  
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Current Office \ MicroStation Issues 

This section describes current known issues with Office documents that are linked or embedded in 

MicroStation. 

 
Error Message “Word cannot start the converter mswrd632.wpc” 
This error is caused because of an operating system security update for Windows first published on December 

8, 2009.   

Microsoft Office uses its own text converters to open Word attachments to MicroStation so this does not truly 

present a problem. The error message appears anytime you either open a Word document embedded in 

MicroStation or when you are embedding a Word document in MicroStation. 

When the error message is encountered, simply click the OK button or the red X in the upper right corner. The 

message will pop up 1 or 2 times more, continue to click until it stops. When the message stops displaying, you 

may need to click on the MicroStation title bar to make it active once more. At that point your document will 

open in Word or if attaching to MicroStation, the Paste OLE option settings come up so you can complete the 

attachment. 

 
Note:  
This issue can be resolved through unregistering the mswrd632 converter by editing the operating system 

registry. The change will effectively unregister the converter and disable it for third-party applications and for 

Microsoft Office.  

Consultants who wish to apply this solution should go to Microsoft online for the appropriate steps to take for 

their systems. As of May 2010, there are no current plans to try to apply the fix on Roadway Design Division 

computers due to the time it would take and since it does not present a serious issue.  
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Word Document Text Not Visible In MicroStation 
After editing a Word document embedded in MicroStation and closing the document, the text no longer 

appears in MicroStation; instead, the attachment appears completely white. 

Although this has only been encountered a few times, it does warrant mentioning. The cause of this problem is 

not currently known but it can be easily fixed.  

Open the document in Word; it should appear normally in there. Then use one of the following methods to 

rebuild the attachment... 

Select all of the text and copy it to the clipboard. In MicroStation, create a new DGN file from the standard seed 

file for those sheets. Open its embedded Word document, select all text and paste from the clipboard and 

save. 

 

or … 

Use Save As and save the Word document outside of MicroStation. Create a blank MicroStation DGN file and 

using regular embedding methods described previously in this document, embed the saved Word document in 

MicroStation.  
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	2nd Sheets Using Office 2010 and MicroStation V8i
	General Information
	Instructions in this document are for development of 2PndP sheets using Office 2010 and MicroStation V8i.
	The process of attaching Office files in MicroStation is called ‘OLE linking’, which stands for Object Link and Embed. It works best to Link Excel files and to Embed Word files when users are attaching Office files to MicroStation. CADD Support has em...
	‘Embedded’ Word documents are available only from inside the MicroStation file.
	‘Linked’ Excel files are external to MicroStation and can be opened & edited from either inside MicroStation or outside of MicroStation directly in Excel. If the Office file is edited separately from MicroStation, the link in MicroStation must be upda...
	The Office OLE attachment is a picture of the Office file. The boundary of the picture is defined by a MicroStation shape element. The OLE attachment can be modified by graphics commands such as move, copy and scale.

	Set up Office 2010
	This is the recommended set up for Office 2010 when using the T.D.O.T. Roadway Design Division templates and programs. If Office templates are not installed to the default folders, then the directions will need to be modified accordingly.
	Do this one time only when using Word and Excel 2010 for the first time with the TDOT templates and programs. This must be done for each user profile in the computer that will be using Office 2010 to link with MicroStation.

	Word:
	1. In Word 2010, click on the File tab at the far left of the ribbon and choose Options from the drop down list.
	2.  In the Word Options dialog click on Save in the options on the left.
	Set the Save Files in this format: option to ʺWord Document (*.docx)ʺ.
	Set the Default file location: Use the Browse button to the right of ʺDefault File Location:ʺ
	Set the folder where you wish all Word documents to be saved by default.
	3.  In the Word Options dialog, click on Advanced in the options on the left.
	Scroll down to the General section and click the File Locations button.
	Click on User Templates and then click on the Modify button.
	Navigate to and set the folder to:
	ʺC:\Users\Public\Office Standardsʺ.
	Click OK to save the setting.
	This will set the default template location for both Word and Excel so that the TDOT template folders will be available.
	4. In the Word Options dialog, click on Trust Center in the options on the left.
	Click on the Trust Center Settings button.
	5.  In the Trust Center dialog, click on Trusted Locations in the options on the left. Then modify as listed:
	a. If you will be using Office documents on a network drive, check the box at the bottom for
	Allow Trusted Locations on my network.
	b. Select the trusted location for ʺWord 2010 default location: User Templatesʺ.
	Click the Modify button.
	All files stored under Trusted Locations will automatically load macros without any action from the user.
	c. In the dialog box, which opens for the User Templates, set the Path by Clicking on the Browse button.
	Select the Path ʺC:\Users\Public\Office Standardsʺ.
	Select on the box for ʺSubfolders of this location are also trustedʺ and click OK.
	6. In the Trust Center dialog, click the Add new location button.
	Click the Browse button and navigate to the location where your project files are stored.
	It is recommended for TDOT personnel that all Roadway Design Projects be stored on your c: drive in a folder named Projects and individual projects in subfolders.
	Click on the ʺSubfolders of this location are also trustedʺ option, key in a description if desired and
	click OK.
	With your project folders defined as trusted locations, all macros will automatically be enabled.
	Your Trusted Locations should look like this.
	If you open a Word 2010 file with macros that is not in a trusted location, the following two settings, numbers 7  and 8 will provide you the opportunity to enable the macros as needed.
	7. In the Trust Center dialog, click on Macro Settings in the options on the left.
	The option ʺDisable all macros with notificationʺ should be set.
	8. In the Trust Center dialog, click on Message Bar in the options on the left.
	The option ʺShow the Message Bar in all applications when active content, such as ActiveX controls and macros, has been blockedʺ should be set.
	9. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings just made.
	10. This completes the settings under Word Options, so click the OK button at the bottom of that dialog to complete the Word 2010 set up.
	Word Template Files
	T.D.O.T. Roadway Design Division Word templates used with MicroStation, are part of the Standard Design and Survey CADD Files and Documents, Office downloads from the TDOT CADD web page. The templates listed below should be in their default folder loc...
	C:\Users\Public\Office Standards\Survey

	 Property Owner Contact Letter - Aerial Flagging.dotm
	 Property Owner Contact Letter - Geotechnical Staking.dotm
	 Property Owner Contact Letter - ROW Staking.dotm
	 Property Owner Contact Letter - Survey.dotm
	 Region 1 Survey Letterhead.dotx
	 Region 3 Survey and Roadway Design Letterhead.dotx
	 Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX.dotx
	 Survey Check List_Field.dotx
	 Survey Check List_Office.dotx
	 SURVEY_SUBMITTAL_CHECK_LIST.dotx
	 SuveyContact_Avery5160_Labels.docx
	 SuveyContact_Envelopes.docx
	C:\Users\Public\Office Standards\TDOT 2nd Sheets

	 Bridge Index.dotx
	 CONSTRUCTION INDEX XXXXXX.dotx
	 Drop Off Notes Traffic Control XXXXXX.dotx
	 EPSC Notes XXXXXX.dotx
	 General Notes XXXXXX.dotx
	 Index and Standard Drawings XXXXXX.dotx
	 PRELIMINARY INDEX TITLE SHEET XXXXXX.dotx
	 RIGHT OF WAY INDEX TITLE SHEET XXXXXX.dotx
	 Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX.dotx
	 SHEET FORMAT FOR 2ND SHEET NOTES XXXXXX.dotx
	 Special Notes XXXXXX.dotx
	 Standard Roadway Drawings XXXXXX.dotx
	 Standard Structure Drawings XXXXXX.dotx
	 Standard Traffic Operations and Structure Drawings XXXXXX.dotx
	 Standard Traffic Operations Drawings XXXXXX.dotx
	C:\Users\Public\Office Standards\TDOT Tab Quantities

	-NONE-

	Excel:
	1. In Excel 2010, click the File tab at the far left of the ribbon and choose Options from the drop down list.
	2. In the Excel Options dialog, click Save in the options on the left.
	Set the option for Save Files in this format:  ʺExcel Workbook (*.xlsx)ʺ.
	Change the path given for Default File Location:
	Set the folder where all Excel documents should be saved by default.
	3. In the Excel Options dialog, click Trust Center in the options on the left.
	Click the Trust Center Settings button.
	4. In the Trust Center dialog, click Trusted Locations in the options on the left.
	Select the trusted location for Excel 2010 default locations: User Templates.
	Click the Modify button.
	All files stored under Trusted Locations will automatically load macros without any action from the user.
	5. In the dialog box, which opens for the User Templates, set the Path by clicking the Browse button.
	Select the Path ʺC:\Users\Public\Office Standardsʺ.
	Select the box for ʺSubfolders of this location are also trustedʺ and click OK.
	6. In the Trust Center dialog box, click on the Add new location button.
	Click on the Browse button and navigate to the location where your project files are stored. It is recommended for TDOT personal that all Roadway Design Projects be stored on your c: drive in a folder named Projects and individual projects in subfolders.
	Click on the ʺSubfolders of this location are also trustedʺ option, key in a description if desired and
	click OK.
	With your project folders defined as trusted locations, all macros will automatically be enabled.
	Your Trusted Locations should look like this.
	Note: If you open an Excel 2010 file with macros that is not in a trusted location, the following two settings, numbers 7 and 8 will provide you the opportunity to enable the macros as needed.
	7. In the Trust Center dialog box, click on Macro Settings in the options on the left.
	The option ʺDisable all macros with notificationʺ should be set.
	8. In the Trust Center dialog box, click on Message Bar in the options on the left. The option ʺShow the Message Bar in all applications when active content, such as ActiveX controls or macros, has been blockedʺ should be set.
	9. Click OK at the bottom of the Trust Center dialog to save the Trust Center settings just made.
	10. This completes the settings under Excel Options, so click the OK button at the bottom of that dialog to complete the Excel 2010 set up.
	Saving Documents with Macros
	If you try to save a new document that has macros with the default file formats, .docx or .xlsx, then you will be warned that all macros will be thrown out since those file types are specifically macro free.
	If you no longer need the macros, simply click Yes to save the file in the macro free format.  Otherwise, click No to stop at this point.
	To keep macros for later use, go to File > Save As
	and under Save As Type choose the macro-enabled one.
	Previously saved documents automatically save in their current format.
	Enabling macros that are not in a trusted location
	If you open a file with macros that is not in a trusted location, a Security Warning message bar will appear.
	If you need to use the macros, click the Enable Content button in the message bar. The Security Warning message bar goes away and macros are ready for use.  Once a document has been trusted, Office 2010 remembers the name so that it will not be necess...

	Excel Template Files
	T.D.O.T. Roadway Design Division Excel templates used with MicroStation, are part of the Standard Design and Survey CADD Files and Documents, Office downloads from the TDOT CADD web page. The templates listed below should be in their default folder lo...
	C:\Users\Public\Office Standards\Survey
	 ROWAcqTable.xltm
	 Survey_Contact_Acq_Create.xltm
	 Survey Weekly Progress Report.xltx
	 Utility Owners.xltx
	C:\Users\Public\Office Standards\TDOT 2nd Sheets
	 Bridge Quantities.xltm
	 Maintenance Quantities.xltm
	 Project Commitments.xltx
	 Estimated Roadway Quantities XXXXXX.xltm
	C:\Users\Public\Office Standards\TDOT Tab Quantities
	 Builder Guardrail Tab.xltm
	 Builder Storm Drainage Pipe Tab.xltm
	 Builder Storm Drainage Structure Tab.xltm
	 OutFalls.xltx

	Estimated Roadway Quantities Excel File
	The Estimated Roadway Quantities Excel file is required on all jobs per the 14TUT.D.O.T. Roadway Design Division Roadway Design GuidelinesU14T. A preliminary construction quantity estimate Excel file shall be submitted to the Estimating and Bid Analys...
	This Excel quantities file is used as an input file for a T.D.O.T. computer database program. The worksheets names, column and row locations and heading information should not be changed or the database program will not input the data correctly.
	The Estimated Roadway Quantity Excel file will contain all worksheets that are needed for a design project. The following worksheets are required but not limited to the following: Project Data, Rdwy Quantity Block 1, Rdwy Quantity Block 2 (if needed, ...
	The Estimated Roadway Quantity file has all of the approved Tabulated Quantity Blocks embedded in it for TDOT Roadway Projects.
	Structures, Maintenance and the Right-Of-Way Utilities Office also have estimated quantities Excel files that they submit to the Estimating and Bid Analysis Office. The templates for these are included in the TDOT 2nd Sheets download.
	The Utility Office provides their estimated quantities Excel worksheet to their users. The Utility Office will send a copy of the utility Excel worksheet to the Roadway Design Division so the “Estimated Utilities Quantities” Sheet 2A3 for the plans ca...
	Save the Excel file to your project folder. Any links attached will not be correct if the Excel file is not saved onto your computer or computer network where your files are stored before attaching them to a MicroStation file.

	Create The TDOT Estimated Roadway Quantities
	It is required that the user have all of the tabulated quantity blocks in the same file with the estimated roadway quantities. By putting all of the worksheets together in the same Excel file, the quantities on the different tab block sheet quantities...
	These directions will first demonstrate creating the Estimated Roadway Quantities file and later describe adding other tabulated blocks.
	1. In Excel, click on the File tab on the far left of the Excel ribbon and choose New
	2. Under New, choose My Templates.
	3. Go to the TDOT 2PndP Sheets tab and select the Estimated Roadway Quantities.xltm template
	Choose the file
	with the latest
	revision date.
	4. Fill in the Project Data sheet. Instruction notes are available on the worksheet. Hold the mouse pointer over the small red triangles for directions. NOTE the rows with RED text (2, 3, 5, 6, 9, 11, 13, 27, 28 and 31) in column “A” are required be f...
	5. When you have filled in all the data for the Project Data sheet click on the Continue Button.
	You will notice the sheet tabs will appear at the bottom of the sheet.
	6. Before you can fill in the Estimated Roadway Quantity Block(s) you must have quantities and they must be tabulated. All tabulated blocks are in this one file. To open a tabulated block sheet click on the tab at the bottom named Add Sheets.
	7. This will bring up a dialog box so the user can choose the Classification and Type of Tab Block need.
	NOTE: All approved Tabulation Blocks are in this file and are hidden. This will unhide them for you.
	For this example, we will open Catch Basins & Manholes Tabulation Block.
	Classification
	Type
	Make your selection and Click Select.
	8. This will open a sheet for the chosen Tab Block as shown.
	Then the user can fill in the data that is need and repeat step no. 7 as many times need to open the Tab Blocks that are required for project.
	UNOTEU:  If you need to remove a Tab Block, repeat step no. 7 and choose the same Tab Block again, and click on Select, and it will be hidden again.
	 In all Tabulated Blocks, the Headers are locked and cannot be edited.
	 Individual cells for things like item numbers and type can be edited, as required.
	 The Tab Blocks are setup for a full sheet of data when placed in a MicroStation file.
	 You may delete Rows as needed to adjust the size (length) of the block.
	 Be careful not to delete the TOTALS Row so the sheet will tabulate your quantities.
	9. The worksheets named: Rdwy. Quantity Block 1, Rdwy. Quantity Block 2 and Box Bridge Quantities Block, contain several macros that are available to help fill out the estimated quantities block. On these worksheets, buttons are provided to access the...

	Estimated Roadway Quantities Macros
	Macro:
	Project Column Format
	These macros listed below will Hide and Unhide the extra quantity columns. These macros should always be used so that the macro buttons and description text to the right will move with the columns and keep the correct format of the table. Micro ʺ1 Pro...
	One Project Column Format
	For most projects, where there is only one project number, the one column format should be used and it is the default table as shown and when the Excel file is open for the first time.
	Note: If the one column format is not shown and you need only one column then Click on the
	ʺ1 Project Column Formatʺ button and the Macro will reformat the sheet.
	Two Project Column Format
	For projects that go across two counties or for another reason have two project numbers Uwith a total uantities columnU, there is the two column format. Click on the ʺ2 Project Column Formatʺ button and the Macro will reformat the sheet.
	Project Column Formatting for 3 thru 5 Column Format
	For projects that go across three counties or for another reason have three project numbers with a total quantities column, there is the three-column format thru five-column format. Click on the ʺ3 Project Column Formatʺ button thru ʺ3 Project Column ...
	Note:  You can Click on the Project Column Format Buttons at any time to Hide or Unhide the columns as needed. But it will nor remove any information you will need to do the manually.
	Do not hide unrequired data! This will cause problems for other users.
	Macro:
	Select Item Numbers From List
	Note:  There are two macros to place item numbers in the work sheets:
	The first is the macro ʺSelect Item Numbers From Listʺ and it uses the Items.dat file.   The file Items.dat must be in the folder C:\Users\Public\Office Standards\TDOT 2nd Sheets.
	The second is the macro ʺImport CSV File for Items.ʺ
	These macros are used to fill in item numbers, descriptions and units.
	They will direct the user to the website to download the items.dat file
	Uif the file is not on the computer in the correct locationU or
	Uif it is more than 30 days oldU.
	1. Uses the Items.dat file located at C:\Users\Public\Office Standards\TDOT 2nd Sheets to find items,
	list them in an Item Select window and write the items selected to the worksheet.
	If the items.dat file is not on the computer in the correct location or if it is more than 30 days old you will see the following block and you will need to down load the items.dat file. It is recommended to always update this file due to item numbers...
	2. Click on ʺSelect Item Numbers From Listʺ
	This will open a dialog box named: ʺOld Database Fileʺ as shown.
	3. Click on ʺDownload Items.dat from the web page now.ʺ
	4. The following web page will open. In the web page named; ʺRoadway Item Listʺ scroll down the blue underlined text ʺUDownload Search Item listsUʺ and click on it.
	5. This will open Windows Explore to RUN an EXE file named ʺRosdwayItemList.exeʺ,  Double Click on it.
	6. This will open a dialog box named: ʺWinZip Self-Extractor – RoadwayItemList.exeʺ as shown.
	Then Click Unzip
	Check Overwrite files without prompting
	This will place the Items.dat file in the right place and overwrite the old file. You can X out of this box.
	7. You should see the following dialog box if the macro works correctly.
	Click OK
	Now you are ready to search and import item numbers in the Estimated Roadway Quantities Block.
	Macro:
	Placing Select Item Numbers & Descriptions In The Roadway Quantity Block
	1. You will need to Click on ʺSelect Item Numbers From Listʺ Again to be able to select item numbers.
	2. You will see the following Dialog box again but now Click on ʺUse existing Items.dat file.ʺ
	This will bring up the Item Select Dialog Box.
	These are the associated buttons:
	Search – If the Search for Items field is left blank, the search button will open all of the items. Put in one or more numbers or letters to pull up all items containing those characters. Do not use any wild card characters. Use the Shift or Ctrl key ...
	Import –  Prompts for the Excel cell to start placing the selected item numbers, descriptions and units.
	Reset –  Clears the Items Found list box.
	Close –  Closes the Item Select dialog box.
	3. The Item Select Dialog Box
	For this example, we typed 705 in the ʺSearch For Itemsʺ window and clicked on Search.
	This will bring all items numbers that stars with 705.            Then we select the desired items.
	4. Click Import.
	This will bring up a dialog box that will ask you for a starting location of the cells to placing the item data.
	5.  Click in the Estimated Roadway Quantities block cell where we want to start placing the item numbers we choose. In the example we selcted B6.
	The imported Item data
	Macro:
	Fill In Description and Unit
	Uses the Items.dat file located at C:\Users\Public\Office Standards\TDOT 2nd Sheets to find items,
	list them in an Item Select window and write the items selected to the worksheet. The macro ʺFill In Description and Unitʺ functions like the macro ʺSelect Item Numbers From Listʺ But only imports one item number at a time and you must know the comple...
	Macro:
	Import CSV File for Items
	GEOPAK produces quantity calculation files in CSV (comma-separated values) format that can be inputted directly into the Excel estimated roadway quantities file. The default CSV file format from GEOPAK is item number, GEOPAK description, units and qua...
	1. You are prompted for the location of CSV file to import.
	Find your file to import, click on it then click on open.
	This will bring up a dialog box that will ask you for a starting
	location of the cells to place the item data.
	2. Then Click
	in the Estimated Roadway Quantities block cell where we want to start placing the item data we choose. Then Click OK. In the example we selcted B6.
	The imported Item data
	To import a CSV file as written for other tabulated quantity worksheets, see macro Import CSV.
	Macro:
	Sort Item Numbers
	The item numbers must be sorted in numerical order by the item number. This macro sorts the item numbers selected by the user and maintains the correct formatting. The macro prompts the user to select the items to be sorted by the cell range in column...
	1. Click on ʺSort Item Numbers.ʺ
	This Brings up the dialog box to select the range for sorting.
	2. Select the range to be sorted by highlighting the Estimated Roadway Quantities Block in column B. For this example, we highlighted B6 thru B20 and it fills in the Select Sort Area dialog box.
	3. Click OK
	Notice the item numbers are now sorted.
	After sorting, the blank lines at the bottom can be deleted and blank lines between groups can be inserted as desired. Select the row by the row number, and right click for row Delete and Insert tools.
	Macro:
	Format Item Numbers
	The borders, text sizes, text justification, fonts, etc. may be changed as the estimate table is being filled in as shown. This macro reformats the estimated quantities block to the original size and proper format.
	1. Click on ʺFormat Item Numbersʺ. Notice the table is now formatted correctly.
	2. Once the table is reformatted, it brings up the dialog box to save the changes.
	If the table looks ok, Click Yes to save the Excel file.
	Macro:
	Import CSV
	This macro brings in a CSV (comma separated values) file to the worksheet selected, starting at the cell selected. This is intended as a way to build tabulation blocks on other worksheets, but can be used to bring the CSV file in without having any pr...
	You are First prompted for the CSV file to import. For this example, we did ROW Markers.
	Select the worksheet & cell location.
	Before Import                   After Import

	Auto-Build Tabulated Quantity Block Macro Access
	These macros are provided as a way to access the macros in the Excel auto-build tabulated quantity block templates. When those templates are inserted as worksheet templates, their macros are not brought in. The macro buttons can be re-assigned to thes...
	BuildCatchBasinsBlock     runcheckitemsCB
	BuildGRBlock        runcheckitemsGR
	BuildStormDrainagePipes     runcheckitemsSS
	See the section Auto-Build Tabulated Quantity Blocks for full descriptions of these macros.

	Alternate Pay Items
	All alternate items must be placed after all of the other roadway items.
	In Column C (the description column) on the line preceding the alternate items, enter the designation for the alternate as ALTERNATE AA1, ALTERNATE AA2, ALTERNATE AA3, etc.
	AA1 will alternate with AA2 and AA3.
	If there were another set of items to be alternated, they would be labeled ALTERNATE AB1, ALTERNATE AB2, ALTERNATE AB3, etc.
	AB1 will alternate with AB2 and AB3.
	A third set of alternates would be AC1, AC2, AC3, etc.

	Additional Estimated Roadway Quantities Worksheets
	To add an additional ʺRdwy. Quantity Block #ʺ Worksheet:
	1. Select the worksheet tab named ʺAdd Sheets.ʺ
	This will bring up a dialog box so the user can choose the Classification and Type of Tab Block need.
	NOTE: All approved Tabulation Blocks are in this file and are hidden. This will unhide them for you.
	For this example, we opened Roadway Quantities Blocks & Rdwy. Quantity Block 3.
	Classification
	Type
	2. Make your selection and Click Select.
	Your New Worksheet
	Note:
	The Project Data worksheet must be the first worksheet in the file, the second set of worksheets are the Estimated Roadway Quantities worksheets with the name Rdwy. Quantity Block # (numbered 1 thru 6 if needed), the third set is the Foot Notes worksh...

	Add Tabulated Quantity Blocks In The Estimate File
	Note: On all tabulated quantity sheets, the TOTALS row of cells contain formulas to sum the contents of the columns or rows.
	1. Select the worksheet tab named ʺAdd Sheets.ʺ
	This will bring up a dialog box so the user can choose the Classification and Type of Tab Block need.
	NOTE: All approved Tabulation Blocks are in this file and are hidden. This will unhide them for you.
	For this example, we opened Storm Drains & Endwalls & Storm Drain Endwalls.
	Classification
	Type
	2. Make your selection and Click Select.
	Your New Worksheet
	Note:  The new worksheet selected may not be in the proper order. To change the order of the worksheets, select the worksheet tab, hold the left mouse button down and then drag and drop to the location wanted.

	Removing Tabulated Quantity Blocks In The Estimate File
	Note: To remove a tabulated quantity sheet that you have opened just repeat the process for opening the sheet. This process will hide the worksheet but will not remove any data you have entered into it.  Do NOT submit an Estimated File with hidden dat...
	1. Select the worksheet tab named ʺAdd Sheets.ʺ
	This will bring up a dialog box so the user can choose the Classification and Type of Tab Block that need to be hidden \ removed. You must choose the exact name of the Tabulation Block for this to work. If you have renamed a tab for a Tabulation Block...
	Classification
	Type
	2. Make your selection and Click Select.
	Your Worksheet Is Now Hidden

	Standard Tabulated Quantity Template Formatting
	1. All fonts are Arial.
	2. Body text is size 9 or 10, not bold.
	3. The main heading text is size 16, bold.
	4. The sub heading text is size 9 or 10, bold.
	5. The TOTALS text is size 12, bold.
	6. The body horizontal lines are light weight.
	7. The heading borders and vertical lines are medium weight.
	8. All justification for cells is preset.

	Auto-Build Tabulated Quantity Blocks
	The following Excel templates include macros that automatically build the tabulation blocks using data files generated by GEOPAK.
	Guardrail Tab Builder.xltm
	Storm Drainage Pipe Tab Builder.xltm
	Storm Drainage Structure Tab Builder.xltm
	Guardrail Tab Builder
	The macro in template Guardrail Tab Builder.xltm builds the guardrail block from a guardrail output file created with GEOPAK’s Design & Computation Manager Pay Items. The macro also runs the Check Items Numbers program to verify all item numbers that ...
	Do not use the Append function in GEOPAK to add guardrail quantities from multiple roadways together in the same file. Instead, generate each roadway guardrail tabulation in separate files and then combine using any text editor. The Append function us...
	In Excel, click the Build Guardrail Block button and the user is given a file open dialog to Select GEOPAK Guardrail Pay Items Output File. Once the file is identified, the macro reads the data and builds the block.
	Different roadways are sorted alphabetically based on the roadway chain name from the output file.
	If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file then it will be necessary to re-assign the macros for the buttons. Select a location away from the macro button, right click over the button and choose the Assi...
	Storm Drainage Pipe Tab Builder
	The macro in template Storm Drainage Pipe Tab Builder.xltm builds the storm drainage pipe tabulation block from the drainage report file created with GEOPAK Drainage using the drainage report format file TDOTlinksFULL.drf. The macro also runs the Chec...
	In Excel, click the Build Storm Drainage Pipe Block button to activate the file open dialog to Select Storm Drainage Link Report File. Once the file is identified, the macro reads the data and builds the block.
	If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file then it will be necessary to re-assign the macros for the buttons. Select a location away from the macro button, right click over the button and choose the Assi...
	Storm Drainage Structures Tab Builder
	The macro in template Storm Drainage Structure Tab Builder.xltm builds the storm drainage catch basins, junction boxes and manholes tabulation block from the drainage report file created with GEOPAK Drainage using the drainage report format file TDOTn...
	In Excel, click the Build Catch Basins and Manholes Block button and the user is given a file open dialog to Select Storm Drainage Node Report File. Once the file is identified, the macro reads the data and builds the block.
	If Insert is used to add this file as a worksheet in the Estimated Roadway Quantities file then it will be necessary to re-assign the macros for the buttons. Select a location away from the macro button, right click over the button and choose the Assi...

	Link Tabulated Quantity Blocks to Estimated Roadway Quantities Worksheet
	To link cells from tabulated quantity block worksheets to the estimated roadway quantities worksheet:
	1. Select the cell where the linked value will be displayed. Enter the equal sign, =
	For this example we will link item no. 709-05.06, MACHINED RIP-RAP (CLASS A-1).
	2. Click to the worksheet and cell to be linked.
	3. Then add an + in the Formula Bar (if you are going to link another tabulation block) and
	click on the second worksheet and cell to be linked.
	4. When the correct worksheet name and cell address are entered into the Formula Bar entry window,
	click on the check mark, ( on the Formula Bar and the total quantity will be linked as shown.
	Note:  Do not have quantities linked to values in separate workbooks.
	The Estimating and Bid Analysis Office will not accept files with links to separate Excel files.

	MicroStation 2d Files for Word and Excel
	Have a 2d design file ready with a sheet border placed in it or open the plans sheet MicroStation DGN file. As with most design files for T.D.O.T. projects, the design file should be created from the T.D.O.T. Roadway Design Division Seed2d.dgn seed fi...
	Name the MicroStation DGN sheet file according to 14TUCADDV8.pdfU14T , Section Roadway Design DGN Project Filenames; Standard Sheet File Types: for all sheet files Use .SHT extension. For example, use the name 002A.sht for the first ESTIMATED ROADWAY ...
	There are several reasons why the MicroStation DGN sheet files need to be named according to the Standard Sheet File naming requirements. One, the project will be very easy to plot using InterPlot Organizer where the sheets will automatically be in or...
	All Second Sheet files must be on a 1:1 scale! The Traffic Control and EPSC Tabulation Blocks shall also be placed on a 1:1 scale. The Right-Of-Way Acquisition Table should be on a 1:1 scale if it is on a sheet by itself or if it is with a Property Ma...
	Creating a New Second Sheet
	1. Open MicroStation SS2 and click on the New File Icon.
	2. In the window that opens to create a new 2nd sheet you need to set the seed type to seed2d.dgn. If it is not set, click Browse and select it. Next, set the location where the file will be created. Select your project Folder where the file is to be ...
	3. In the window that opens select the file and click OPEN.
	4. When the MicroStation file opens, the first thing the user needs to do is set the active scale to 1:1 for second sheets. In the Menu Ribbon at the top of MicroStation select Utilities and dropdown to Key-in and click on it to open it.  Key in as=1,...
	5. Now we place SaS sheet cell. In the Menu Ribbon at the top of MicroStation, select T.D.O.T., and pull down to Sheet Cells and click on it.
	6. This will bring up a dialog box to select your sheet border. Click on, Plan for Tabulated Quantities.
	7. This will activate the sheet cell the user needs to place the cell in the MicroStation file by clicking in the MicroStation view window where they want to place the cell. The sheet cell should look like this.
	The sheet cell has snap points for placing the Estimated Roadway Quantity blocks by corners. The Yellow snaps points are for placing the quantity block on the left side of the sheet. The first snap point is for placing the beginning corner point of th...

	Excel Linking to a MicroStation File
	Linking The Estimated Roadway Quantities Block
	1. Open your Estimated Roadway Quantity file. For this example, we will use the Rdwy. Quantity Block 1. All tab blocks have been setup so the top row and the row just below the table is one cell each, to make it easy for selecting. Select the informat...
	2. Right click on your mouse and pick Copy from the choices given. This puts the selected information into the Windows Clipboard.
	3. In your MicroStation file on the menu bar, go to Edit > Paste Special…
	(The Excel link will be placed on the active level in MicroStation)
	Select the Linked Microsoft Excel Worksheet option and click the Paste button,
	4. Select the Method: By Corners.
	5. Snap to the left Yellow snap point then second Yellow
	Snap point and the Rdwy. Quantity Block 1
	is placed on the sheet in your DGN file.
	You now have a live Excel file linked to your DGN
	file so when you make changes in your Excel file
	they can be updated without attaching the file again.
	Linking The Foot Noes
	6. Open your Estimated Roadway Quantity file. For this example, we will use the Foot Notes. All tab blocks have been setup so the top row and the row just below the table is one cell each, to make it easy for selecting. Select the information in Excel...
	7. Right click on your mouse and pick Copy from the choices given. This puts the selected information into the Windows Clipboard.
	8. In your MicroStation file on the menu bar, go to Edit > Paste Special…
	(The Excel link will be placed on the active level in MicroStation)
	Select the Linked Microsoft Excel Worksheet option and click the Paste button,
	9. Select the Method: By Corners.
	10. Snap to the left Purple snap point then second Purple
	Snap point and the Foot Notes are placed on the sheet.
	Again you have a live Excel file linked to your DGN
	file so when you make changes in your Excel file
	they can be updated without attaching the file again.
	Linking The Tabulated Quantities Blocks
	11. Open your Estimated Roadway Quantity file. For this example, we will use the STORM DRAIN ENDWALLS Tabulation Block. All tab blocks have been setup so the top row and the row just below the table is one cell each, to make it easy for selecting. Sel...
	12. Right click on your mouse and pick Copy from the choices given. This puts the selected information into the Windows Clipboard.
	13. In your MicroStation file on the menu bar,
	go to Edit > Paste Special…
	Select the Linked Microsoft Excel Worksheet
	Option and click the Paste button,
	14. Select the Method: By Size.
	Click on Rotate With View.
	Set the Scale to: 18.
	All Tabulation Blocks are set up to be placed on a scale of 18.
	The Active Scale and the Sheet file in the DGN file must be on a 1 to 1 scale.
	15. Place the Tabulated Block anywhere inside the sheet border in the DGN file by clicking with your mouse that now has the Tab Block attached to it.
	16. You will need to move the Tab Block you just attached to the top left corner of the sheet. You must save and close your Excel file to be able to move the attach file in MicroStation. Snap to the top left corner of the attached tab block to pick it...
	Again you have a live Excel file linked to your DGN file so when you make changes in your Excel file
	they can be updated without attaching the file again.
	Linking Multiple Blocks To One Sheet
	All Tabulated Quantity Blocks are set up for a full sheet for each block. In most small jobs, you will not need a full sheet of most tables. All Tabulated Block have been set up so the user can delete the rows needed to be removed to make the table th...
	Note: It is ok to have one Tabulated Block per sheet in the design project, but if there is a need to place multiple blocks on one sheet then repeat steps 11 thru 16 to have the blocks placed in upper left corner at the Blue Snap Point.
	17. In this example, we have attached two blocks to the Blue Snap Point in the upper left corner of the sheet. The two blocks have been edited by removing the rows we do not need (rows 9 thru 54) in our blocks. The user will need to move the blocks of...
	If your Tabulation Block extends into the area under the 4 inches under the Project ID Block in the upper right corner than something did not attach correctly.
	It is recommended that each time a Tabulation Block is attached in a MicroStation file that the user compress design, save settings, exit completely out of MicroStation and reopen it before attaching another Excel or Word file.
	Excel Text Size in a MicroStation File
	All text in the Estimated Roadway Quantity file that has the Tabulated Quantity Blocks is based on the Arial font and the blocks are set to be placed at a Scale 18. This should produce a text size values for .14 for the rows in the middle of all tab b...
	The Arial font, text size 9 in an Excel Tab Block when placed at a scale 18 will measure in the DGN file a height of .14 feet.
	1-scale size sheet, set the scale to 18 for placement:
	Main Body text size 9 in Excel will measure 0.14 UfeetU in MicroStation
	Table Name text size 16 in Excel will measure 0.24 UfeetU in MicroStation
	Total Row text size 12 in Excel will measure 0.18 UfeetU in MicroStation
	50-scale size sheet, set the scale to 900 for placement:
	Main Body text size 9 in Excel will measure 7 UfeetU in MicroStation
	Table Name text size 16 in Excel will measure 12 UfeetU in MicroStation
	Total Row text size 12 in Excel will measure 9 UfeetU in MicroStation
	0TBecause the Excel file link is attached as a picture, the text cannot be measured directly. Zoom in and use the measure tool to see if the body (not the headings) text is approximately the correct size0T.
	Open & Update the Excel OLE Attachment
	The changes made to the Excel files outside of MicroStation will not be changed in MicroStation until the Excel links have been opened & updated.
	Use one of the following methods:
	1. In MicroStation, start the Element Selection tool and double click on the link to be revised. The Excel file is opened. Make any changes that may be needed and save the file. The link is updated in MicroStation.
	2. In MicroStation, go to Edit > Links… In the Links dialog, select the link to be revised and click Open Source. The Excel file is opened. Make any changes that may be needed and save the file. The link is updated in MicroStation.
	You should not use the Update Now option in the Links dialog without opening the document first. The link may be updated but errors are generated and you may corrupt your MicroStation file.
	3. In MicroStation, select the link to be revised and the Worksheet Object tools are enabled. Go to Edit > Macro-Enabled Worksheet Object > Edit. The Excel file is opened make any changes that may be needed and save the file. The link is updated in Mi...
	4. Open all linked files in Excel. In MicroStation, go to Edit > Update Links.
	This function should update all of the links in the file without opening the links. When used with Office 2010, errors are generated and nothing may be updated.
	Relinking
	When the sizes of the rows are changed, the area linked will still be displayed in MicroStation but will be warped or truncated. It will need to be relinked to correct the display in graphics.
	To relink an Excel file:
	1. Move the existing linked graphics away from the sheet border.
	2. Open the Excel file.
	3. Follow the directions for a new link. See section 5TExcel Linking to MicroStation5T6T.
	4. After the new link has been established and is correct, the link graphics from the old link can be deleted.

	Word Embedded in MicroStation
	Word Documents Embedded in MicroStation DGN Seed Files
	There are MicroStation design seed files set up for the 2PndP sheets with the T.D.O.T. Word documents embedded. These seed files have sheet borders set up at a one-scale.
	MicroStation seed files with embedded Word documents:
	 BLANK SHEET FOR 2ND SHEET NOTES XXXXXX.dgn
	 Drop Off Notes Traffic Control XXXXXX.dgn
	 EPSC Notes XXXXXX.dgn
	 General Notes XXXXXX.dgn
	 Index and Standard Drawings XXXXXX.dgn
	 Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX.dgn
	 Special Notes XXXXXX.dgn
	 Standard Roadway Drawings XXXXXX.dgn
	 Standard Structure Drawings XXXXXX.dgn
	 Standard Traffic Operations and Structure Drawings XXXXXX.dgn
	 Standard Traffic Operations Drawings XXXXXX.dgn
	Creating a Second Sheet from a Seed File in MicroStation
	1. From MicroStation or MicroStation manager,
	Go to File > New in MicroStation or click the New File icon in MicroStation Manager …, and in the project folder, Browse to select the seed file needed for the sheet, assign the name according to TDOT CADD’s sheet namSeSing conventions and assign a *....
	There are several reasons why the MicroStation DGN sheet files need to be named according to the Standard Sheet File naming recommendations. One, the project will be very easy to plot using InterPlot Organizer where the sheets will automatically be in...
	The OLE link is displayed as a ‘picture’ of the Word document. It has a shape around the edge. The OLE link can be copied, moved or scaled using the graphics commands.
	7TUSeed file Editing Notes: U7T
	1. In MicroStation, use the Element Selection tool and double click on the embedded Word document. The embedded document will open in Word.
	2. Note that the Word document header says Document in DesignFileName.sht. Make edits as needed.
	3. Occasionally information previously deleted needs to be added back into the Word document. This can be accomplished by cutting and pasting from other open Word documents. To open a temporary General Notes or Index and Standard Drawings file in Word...
	In General Notes documents, each section is numbered starting at 1 (one). If the 1PstP note in a section is deleted, the remaining notes will pick up the numbering sequence from the previous section. To correct this, highlight the first note in the se...
	4. After making the edits wanted, go to the File tab at the upper left and choose Save or click on the Save icon at the upper left. Changes made in the Word document will not be shown in MicroStation until the Word document is closed.
	5. The only access to an embedded document is from the graphics in the MicroStation design file. If the graphic display of the embedded Word document is deleted, the Word document will be deleted. If MicroStation has not been closed and the file has n...
	For this reason, it is recommended that a copy of the Word file information be made after significant edits have been done.
	This can be done several ways. In the Word document, go to the File tab at the upper left and select Save As to make a copy to the project folder. In MicroStation, the OLE link graphics can be copied to the side creating separate OLE link of the edits...
	7TUSpecial Info in the Word Header & Text Body  U7T The Header:
	There is special text in RED, which is the latest Updated Date for this file and the Instructional Bulletin(s) that the file was updated to their requirements.
	There is special text in Black, which list the Effective Date for the data in the word file.
	There is special text in Blue, which is special instruction of the user.
	The Body of Text:
	There is special text in Blue, which is special instruction of the user.
	More than one Sheet Needed
	If more than one plan sheet will be needed for General Notes or Index sheets:
	1. Make edits as needed to the Word document embedded in the first sheet and close the Word document.
	0TSince the text is not easily moved from one MicroStation design file to another, it is recommended that all of the edits be made to the first MicroStation General Notes or Index design file before creating the additional sheets.
	2. Repeat step 1 under section Creating a Second Sheet from a Seed File in MicroStation as listed below.
	From MicroStation or MicroStation manager,
	Go to File > New in MicroStation or click the New File icon in MicroStation Manager …, and in the project folder, Browse to select the seed file needed for the sheet, assign the name according to the sheet name directions and assign a *.sht extension....
	3. In the new MicroStation sheet file, edit the Word document. Highlight all of the text (except the heading if needed) on the first page in the Word document and delete it. Save & close the Word document to see the changes in the MicroStation file.
	4. Repeat as needed for additional sheets.
	Embedding Word Documents in Existing MicroStation DGN Sheet Files
	Sometimes you need to add small groups of notes to existing plan sheets in MicroStation.
	This section describes the process of embedding the Word documents in MicroStation.
	The TDOT Word documents embedded in the MicroStation seed files are also available as Word templates. These can be used to add notes or standard drawings back into full sheets as needed.
	T.D.O.T. Roadway Design Division Word templates used with MicroStation at
	C:\Users\Public\Office Standards\TDOT 2nd Sheets:
	 BLANK SHEET FOR 2ND SHEET NOTES XXXXXX.dotx
	 Drop Off Notes Traffic Control XXXXXX. dotx
	 EPSC Notes XXXXXX. dotx
	 General Notes XXXXXX. dotx
	 Index and Standard Drawings XXXXXX. dotx
	 Sheet 3 ROW Notes Utility Notes Utility Owners XXXXXX. dotx
	 Special Notes XXXXXX. dotx
	 Standard Roadway Drawings XXXXXX. dotx
	 Standard Structure Drawings XXXXXX. dotx
	 Standard Traffic Operations and Structure Drawings XXXXXX. dotx
	 Standard Traffic Operations Drawings XXXXXX. Dotx
	A Full Sheet of Notes
	1. In Word, go to the File tab at the upper left, choose New > My Templates > TDOT 2nd Sheets, and select the type note file needed. (Or use your own note files)
	(Note: if you use a non TDOT 2nd  Sheet template the following scales for the sheets will not be correct.)
	2. Edit the notes as needed. Select and copy to put the text into the Windows Clipboard.
	3. In your MicroStation file on the menu bar,
	go to Edit > Paste Special…
	Select the Embedded Microsoft Word Document
	Option and click the Paste button.
	4. If you are placing a Full Sheet of Notes in a Second Sheet that is 1:1 scale then you should use a Sheet Border that has the Snaps Points at the top of the sheet.
	Select the Method: By Corners.
	Click on Rotate With View.
	5. Place the Word Note File by clicking with your mouse on the Snap Points at the top of the Sheet File.
	Text Size for a Full Sheet of Text
	Arial font is the standard Font, text size 7 for normal text in Word (font and size in TDOT templates):
	1-scale size sheet:
	Text Size 13 for .14 text size  -   this will measure 0.14 UfeetU in MicroStation
	and will measure 0.14 UinchU on the printed sheet
	Text Size 11 for .12 text size
	Text Size 9 for .10 text size
	50-scale size sheet, multiply the dimension above by 50:
	Text Size 650 for .14 text size
	Text Size 550 for .12 text size
	Text Size 450 for .10 text size
	Placing a Word File on a Layout Sheet
	1. In Word, Select and copy your Text into the Windows Clipboard that you want to place in the DGN file.
	2. In your MicroStation file on the menu bar,
	go to Edit > Paste Special…
	Select the Embedded Microsoft Word Document
	Option and click the Paste button.
	3. Select Paste as: Embedded and Method: By Size.
	Under the extra options, click on Rotate With View.
	4. Set the Scale Size. The following only works if the text is Arial and 7 point size in the Word document.
	This is what the TDOT Standard Note size is based on.
	If the DGN sheet scale is 1:1 than set the scale to 38.
	If the DGN sheet scale is 50:1 than set the scale to 1900.
	5. Data point at the location on the DGN file where the Word file is to be placed.
	6. Use MicroStation’s Move Element command to position the link as needed. The temporary Word document used to copy the notes from can be closed without saving since the document is now embedded in the MicroStation DGN file.
	Additional Notes concerning this method of Embedding
	The By Corners method is used for Word documents to ensure that the text comes in at the correct size. The By Scale method does not yield consistent results when used with Word attachments. That method is used with Excel attachments.
	Because the embedded Word file is attached as a picture, the text cannot be measured directly. Zoom in and use the measure tool to see if the body (not the headings) text is approximately the correct size.
	Open & Update the Word OLE Attachment
	Embedded Word Documents

	In MicroStation, start the Element Selection tool and double click on the document to be revised. The Word file is opened. Make any changes that may be needed and save the file. The document is updated in MicroStation.
	Linked Word Documents

	Linking Word 2010 documents instead of embedding them is not recommended due to several compatibility issues between Word 2010 and older versions of MicroStation. Any made with Office 2010 will have to consider the following if it is necessary to open...
	Word 2010 documents linked to MicroStation cannot be opened from inside MicroStation and they cannot be updated until they are open in Word.
	In order to update these after being linked, you must first open the document through Word 2010. After making any needed edits, save the file and then with it open in Word, use one of the following methods to update what appears in MicroStation.
	1. In MicroStation, go to Edit > Links… In the Links dialog, select the link to be updated and click Update Now.
	2. In MicroStation, go to Edit > Update Links.
	To use this method, it will be necessary to open all linked files first.
	It should update all of the links in the file without opening the links but when used with Office 2010 without the files open, errors are generated and nothing is updated.  Correcting Overlapping Text from Embedded Word Documents
	With previous versions of Office and MicroStation when the height of the text area in the embedded Word document was reduced from what it was when originally set up, then the text became warped causing text characters to overlap. This could occur when...
	This problem appears to be corrected with Office 2010 and MicroStation V8i.  If you are using MicroStation V8 2004 then you may still run into it.
	Take the following steps to re-embed the document and correct this problem:
	1. After edits are done to the embedded Word document, the text becomes warped and overlaps in MicroStation.
	2. Open the document and in Word go to the Office button at the upper left and select Save Copy As… to save the document outside the MicroStation DGN file to your project folder.
	3. Open the Word document from your project folder, select and copy to put the text into the Windows Clipboard.
	4. In MicroStation, delete the original embedded document or move it to the side off the sheet.
	5. The OLE attachment will be placed on the active level, reset as desired.
	6. In MicroStation, go to Edit > Paste Special…, select the Embedded Microsoft Office Word Document option and click the Paste button.
	7. Select Paste as: Embedded and Method: By Corners. Under the extra options, click on Rotate With View.
	8. Data point at the location where the upper left corner of the data needs to start on the sheet. This sets the first corner and you are prompted to Select Rectangle Corner.
	9. In the MicroStation keyin field enter the required dx= keyin to set the corner across from the first point.
	The scale of the plan sheet as the width dimension of the document inside of Word determine the dimension used in this keyin. General Notes and Index sheets are set up as full sheets in Word at 11” X 17” and in MicroStation at a scale of 1 so you shou...
	After re-embedding …

	Formatting Word Documents
	The Office 2010 interface includes a series of tab options across the top, each of which displays a “ribbon” of command options. As you expand or shrink the width of the Office window, these commands are adjusted to show less or more. You can right cl...
	When you right click from text in your document, some quick formatting tools are shown above the regular right click option list.
	Show/Hide Formatting
	The Word documents created for TDOT plans production contain special formatting so they will appear correctly on the plan sheets. Text styles, tabs, bullets and numbering, paragraph indents, hanging indents, columns, column breaks, page breaks and mor...
	To display the formatting characters, use the Show/Hide display command. It is located on the Office 2010 ribbon under the Home tab in the Paragraph section. It appears as a paragraph mark.
	Click on the Home tab. Look at the Paragraph section of the ribbon and click on the Paragraph mark to Show/Hide formatting characters.
	Clicking the paragraph mark will toggle off and on the display of the formatting characters. When it is toggled on, we can see section breaks, paragraph marks, tabs, etc.
	Text Styles in Word
	A text style will set all of the characteristics for the specified text. This includes font, font size, tabs, indents, color, heading, bullets and numbering, etc. There are text styles for each type of text used in the TDOT 2PndP sheet Office template...
	Text style controls can be found on the Word 2010 ribbon under the Home tab in the Styles section.
	Word 2010 includes a type of style control called Quick Styles. When you move your cursor mark over the quick style it temporarily applies that style to the entire paragraph where your typing insertion point is currently located. In the example below,...
	Click the arrow with the line above it at the bottom of the Quick Styles scroll bar to see all of the quick styles currently available.
	There are two ways to access the standard TDOT 2PndP sheet text styles. You can click on the Apply Styles option, which appears at the bottom of the Quick Styles drop down menu shown above. This opens up the Apply Styles dialog. You could also click t...
	Indents, Hanging Indents, Line Spacing, Tabs, etc.
	To see the indents, hanging indents, tabs, etc. put the cursor at the text/paragraph in question, right click and select Paragraph. Note that the Tabs can be accessed at the lower left of the dialog. To change any of these settings, select the text to...
	You can also access the Paragraph dialog on the Office 2010 ribbon under the Home tab in the Paragraph section. Click the small square with the arrow in it at the lower right of the Paragraph section title bar.
	Indent & Spacing controls can also be found on the Office 2010 ribbon under the Page Layout tab in its Paragraph section.
	Numbering & Bullets
	You can access Numbering and Bullets on the Office 2010 ribbon under the Home tab in the Paragraph section. Click either of these to use the current active format or click the arrow next to them to pull out the drop down menu for them. From the drop d...
	Position yourself in a given numbered paragraph and right click for various numbering controls.
	Page Setup
	You can access Page Setup on the Office 2010 ribbon under the Page Layout tab. The Page Setup section includes controls for the margins, orientation, size and columns of the page.
	The TDOT General Notes and Index & Standard Drawings templates have a paper size of 11” x 17” and use a landscape orientation.
	Columns
	You can also access Column formatting controls in the Page Setup section on the Office 2010 ribbon under the Page Layout tab.
	The TDOT General Notes and Index & Standard Drawings templates are set up into three columns. The number of columns and justification can be set from the Column drop down menu.
	To set widths and other column settings, select the More Columns option from the drop down menu to open the Columns dialog.
	Breaks
	You can also access the Break controls in the Page Setup section on the Office 2010 ribbon under the Page Layout tab.
	Turn the Show / Hide formatting display on to see page, column and section breaks. Use the Delete key to remove a break. Use the drop down menu from Breaks in the Page Setup section to insert a page, column or section break as needed.
	You can also insert a Page Break from the Pages section on the Office 2010 ribbon under the Insert tab.

	Current Office \ MicroStation Issues
	This section describes current known issues with Office documents that are linked or embedded in MicroStation.
	Error Message “Word cannot start the converter mswrd632.wpc”
	This error is caused because of an operating system security update for Windows first published on December 8, 2009.
	Microsoft Office uses its own text converters to open Word attachments to MicroStation so this does not truly present a problem. The error message appears anytime you either open a Word document embedded in MicroStation or when you are embedding a Wor...
	When the error message is encountered, simply click the OK button or the red X in the upper right corner. The message will pop up 1 or 2 times more, continue to click until it stops. When the message stops displaying, you may need to click on the Micr...
	Note:  This issue can be resolved through unregistering the mswrd632 converter by editing the operating system registry. The change will effectively unregister the converter and disable it for third-party applications and for Microsoft Office.
	Consultants who wish to apply this solution should go to Microsoft online for the appropriate steps to take for their systems. As of May 2010, there are no current plans to try to apply the fix on Roadway Design Division computers due to the time it w...
	Word Document Text Not Visible In MicroStation
	After editing a Word document embedded in MicroStation and closing the document, the text no longer appears in MicroStation; instead, the attachment appears completely white.
	Although this has only been encountered a few times, it does warrant mentioning. The cause of this problem is not currently known but it can be easily fixed.
	Open the document in Word; it should appear normally in there. Then use one of the following methods to rebuild the attachment...
	Select all of the text and copy it to the clipboard. In MicroStation, create a new DGN file from the standard seed file for those sheets. Open its embedded Word document, select all text and paste from the clipboard and save.  or …
	Use Save As and save the Word document outside of MicroStation. Create a blank MicroStation DGN file and using regular embedding methods described previously in this document, embed the saved Word document in MicroStation.


